Jump to content
Corsair Community

ASUS P5k new CM2x1024-6400C4 modules = :S


Recommended Posts

Ok, I've tried several things which have left me scratching my head, hopefully someone here will know where I'm going wrong, please bear with me!


I've been running the P5k with a TWIN2x2048-6400C4 kit for several months now, all fine (Vista x64).


On these modules the bios seemed to default to 667mhz so I bumped it up to 800 in line with the module specs, everything else set to 'Auto'. This was all CL=5, I've tried 4-4-4-12 with the dram-V boosted to 2.1v but windows is unstable, so I stuck with CL=5. On further inspection it's branded XMS6464 ver2.1. My bios has been updated now to the latest and vista is up to date etc.


Now, I purchased another identical set recently, which don't work very well at all, at first I ran the entire 4gig paired up as they should be, all at CL=5 800mhz, I kept getting app's closing randomly so I ran a memtest and everything over address 2900mb was giving tonnes of errors. So aha this must be faulty ram, I returned it only to be in the same situation with the replacements.


After some digging around on this forum, I set them up on 667mhz CL=5 (i.e. Auto) and dramV to 2.1v, but still the same problem. More worryingly if I just put 1x1024 in, of the new modules, on any setting I tried, windows will either boot then crash fairly soon or BSOD on startup.


wtf is going on? these new modules are branded '2.10v ver2.1' ..6400C4 G. I mean they should work on default settings with only a gig in no? or am I just unlucky enough to have part of a faulty batch (or a fault MB)?



Link to comment
Share on other sites

  • Corsair Employees

Please make sure that you have the latest Bios version and then load setup/optimized defaults and set the Dim Voltage to 2.1 volts (+.2 Volts W/Giga-Byte) and then set the timings manually to the tested settings for the specific module you have, (Cas 4-4-4-12 2t CR TRC 24) and then test the module/'s one at a time with http://www.memtest.org! If you still get errors, please follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it! However, if you get errors with both modules that would suggest some other problem and I would test them in another system or MB to be sure. In addition, with some MB's (Mostly ASUS) you have to disable legacy USB in the bios when running any memory test.


If they all pass set the memory frequency at DDR667 with all four installed and set the NB/MCH Voltage to +.05 Volts and test with http://www.memtest.org.


Also You'll need to install MS patch 929777 from Microsoft for more than 3 GIG in Win Vista. You can search for it at http://www.microsoft.com. If you are using Vista!

Link to comment
Share on other sites

With all four DRAM banks being populated, you will very likely have to drop the DRAM bandwidth from 800Mhz to 667Mhz. The on motherboard memory controller (MCH/Northbridge) can not access and load with four DRAM banks as it can with two DRAM banks at the rated 6400 speed. If you had purchased 4 X 1024MB of PC8500 (1066Mhz) DRAM, then you would have had to drop to PC6400 (800MHz) DRAM, etc. 2 X 2048 will not issue this problem. This is a problem of all 4 banks being populated.


Think of it this way. If you have a small phone book, then when you go into the index to find the page where you will find the phone number you are doing so at a certain speed due to the pages of the Index. Then you have to drive through the pages to get to the number. Now if your index is twice as large and the pages twice as many, then it takes longer to access the data. Now DRAM has a Strobe and the length of the strobe is how long the rows and columns can be left open before they must be refreshed. There is not enough time for the dram to be refreshed and then accessed with 4GB at the full access speed of the DRAM. The chipsets are optimized for 2GB, not 4GB and for 2 DRAM slots, not 4 DRAM slots populated. You can overclock the FSB (and hence the Memory Controller Hub = MCH) to gain some extra bandwidth and thus access the capabilities of the DRAM since the chipset is now clocked up. Usually when you clock up the FSB and concurrently the Memory Controller Hub (MCH) you need to raise the voltages of the CPU/MCH a bit as well.


So insert two sticks in the first and third slot, shut the system down, reset the BIOS by removing the power cord and removing the CMOS battery. Leave out for 10 minutes or so and re-insert the battery/power cord. Restart the system, enter the BIOS, load default settings, save default settings and set the DRAM to 667Mhz. Set the MCH (Memory Controller Hub) to 1.45v and the Vdimm to 2.1v. Shut the system down and memtest. If it passes, then shut the system down, remove the two stick and insert the second set of sticks in their place. Retest. If they also pass the test. Then shut the system down and insert the first set in the second and forth slot. Remove the second set. Now you should have one set in the second and fourth slot. Retest. If it passes, then populate all four slots. Retest.

Link to comment
Share on other sites

Thanks for the repiles, but if you'd read the post I'd tried most if not all of what you suggested.


I hadn't tested the modules seperately with memtest though, guess I should have checked the basics. So yes 1 of the new modules gave 3072 errors at around 50%, I thought it was unlikely I'd have another faulty module after getting them replaced, looks like I was wrong.


The other 1 in the pair was 100% fine though, so I imagine it's a faulty batch as the replacement came from the distibutor level (like the original set I returned) and not corsair directly.


SN: 178228 08030295 if your interested ram guy.


Sod's law I guess :sigh!:

Link to comment
Share on other sites

but if you'd read the post I'd tried most if not all of what you suggested.


First of all, I did read your post. I disagree that you had already tried most of what I posted. You did not state that you fully cleared and drained the CMOS as well as the capacitors. You did not state that you loaded default settings, saved default settings and then began a testing of the DRAM. The above often clears up stack corruption in the CMOS and/or SRAM caches. Testing the DRAM without performing the above, can often return errors even when the DRAM is in actuality fine.


At any rate, you seem to have found the issue.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...