Jump to content
Corsair Community

acer 5720 problem


Recommended Posts

hi just bought two corsair pc2-5300 2gb ddr2-667 for my laptop.

the acer sight says I can handle 4gigs in this model(5720z-4643) and your config page says that these are the right moduals and are compatable.

if I install both dimm's, the computer will boot to the login screen and then generate video artifacts and lock up. when you boot to an ultimate boot cd to run mem test, the same happens(video artifacts and then lockup)

installing a single sim will boot the machine properly regardles of which sim or which slot(ie sima in slot1 works sima in slot2 works simb in slot1 works simb in slot2 works)

there are no settings for me to be able to adjust timing and whatnot in the bios. the bios does see 4gig ram when both sims are installed.

I have updated the bios to the latest ver 1.25(previously 1.18) with no change.

I do not think this is a video driver issue as it is doing the same thing when booting to "ultimate boot cd" for memory tests.

I am going to now run a mem test on each sim in each slot to ensure but that should take a little while.


ps the power was unplugged and the battery removed with the power switch held to drain caps prior to all ram adjustments.


thank you for your time.


acer aspire 5720z (5720-4643)

dual core t2310 1.46ghz

Link to comment
Share on other sites

memtest generates no errors with dimma in slot1 or slot 2 and dimmb in slot1 or slot2(several hours of testing later :))

memtest generates a video artifact and locks up if both dimms are installed in the machine regardless of which dimm is in which slot


anybody have any suggestions of what to try next

thanks for your time

Link to comment
Share on other sites

thank you for your reply. I have followed your suggestions and am posting the results for further suggestions.


as stated previously, the acer bios was updated from v1.18 to v1.25(latest) in the previous bout of testing with no change in this problem.


I have downloaded the iso you linked to(I was using the same software but a an earlier version 1.86) and repeated all the tests again with the following results.


dimm(a) in slot(1) no errors

dimm(a) in slot(2) no errors

dimm(b) in slot(1) no errors

dimm(b) in slot(2) no errors

dimm(a) in slot(1) & dimm(b) in slot(2) video artifact and system lock(described in better detail below)

dimm(b) in slot(1) & dimm(a) in slot(2) video artifact and system lock

old512 in slot(1) & dimm(a) in slot(2) no errors

old512 in slot(1) & dimm(b) in slot(2) no errors

(I have used the known good in slot1 and unknown in slot2 before to catch errors on ram that would not error when in slot1 due to reserved memory. I am not sure if it makes any difference in dual channel mode :ie does it reserve half the amount from each chip or the full amount from chip1)


explaining "video artifact and system lock" when using the new version of memtest, I am able to see A little more and I will try and describe what is happening as this may give some insight. as before windows splash screen loads and when it gets to the login screen there is severe video artifacting and the omputer will not respond to the keyboard(ctrl alt del does not function power button must be held for 6 seconds to power off). In memtest86+ v2 everything loads and it starts testing. at 50% of test#0 there is a small video artifact. the second m in memtest86+ top right of the screen goes from black letter on green background to a black box and on the l2 cache line in between the cache size and cache speed one character goes from blue to black. THEN at about 30%(hard to tell very fast) of test#1 the whole screen goes into a funky checkerboard the background color changes in blocks of four or five characters wide(columns) by the same in rows ie a 4x4 block background changes from blue to black then the next 4x4 stays blue and the next 4x4 goes black. ALSO the characters become random ascii instead of letters and numbers. ALSO the esc button does not stop the tests and reboot the machine, the power button must be held for 6 seconds to power down the machine.


the video artifacts ONLY happen when BOTH 2gig sticks are installed.(and yes I did do a "load setup defaults" when changing the ram configs as suggested)


I thank you for your time and expertise and apologize for being so verbose but the more information you have, the faster I can resolve the issue one way or the other. I look forward to your comments and any possible suggestions.

Link to comment
Share on other sites

I am going to tag onto your thread, since my experience has been exactly like yours. Both of the new sticks Corsair 2048MB PC5400 DDR2 667MHz SODIMM that the Corsair memory configuration suggested for my computer work with no problem in any slot individually, but will not run if both are installed. You are getting a little further on you boot up, since you can actually see something on your screen. When I power mine up the hard drive light comes on for 2 seconds, then goes out leaving nothing but a big black screen. Did you buy yours as a 4gb kit or separately? I have a ticket in with the ram guy, but it is taking some time to get any replies. If you find some how to make work yours let me know, and I will do the same. Thanks :sigh!:
Link to comment
Share on other sites

but you have a different situation than mine :)

there are two acer 5610. one a 5610 with a 945gm chipset that supports 4gig and also a a 5610z that uses the 943gml chipset. The 943gml chipset only supports 2gig of ram see http://www.intel.com/products/chipsets/943gml/index.htm

also the 5610 is listed in the configator while the 5610z is not (as signified by the the 945gm and 945pm listed and the 943gml NOT listed)


I appreciate your post as it may have lead to a clue that would help solve my issue but I fear you are stuck at the 2 gig cieling. Good luck selling your ram :)

Link to comment
Share on other sites

Response (Online Agent-03) - 02/11/2008 11:32 AM

Dear Sean Robertson,


Thank you for contacting Acer America. We apologize for the delay in responding to your inquiry. As Acer America does not test third party hardware we are unable to provide technical support or recommendations regarding this issue. For assistance with this issue, it will be necessary for you to contact the manufacturer of this memory.



Acer America

Online Technical Support


Customer (Sean Robertson) - 02/09/2008 04:50 AM

I am having some problems upgrading my ram from 2@512 to 2@2048.

your site said the laptop would take 2@2048 and the ram manufacture said that for my model, I had 100% compatability with the sticks I purchased. these sticks are corsair vs2gsd667d2 pc2x5300 200 pin sodimm.

I am getting a strange video artifacting and system lock when both sims are installed. with either 2gig simm by itself, everything is ok and if I mix one 2gig and one 512, everything is ok. BUT both 2gig and the systems locks up.


the machine will run through the windows splash screen and when it gets to the login screen, the video becomes unreadable and stops responding to the keyboard. ALSO when booting from a bootable cd to run memtest86+ v2.00 the test will start running and then the screen will show video artifacting and stop responding to the keyboard.


The ram has been tested thouroughly and has passed with no errors in several different configurations. I have also updated to the latest bios for my laptop from the acer support site old v1.18 new v1.25 no change in behaviour. I suspect there is something going on with the video controller and 4096meg of ram but would like suggestions from your experts. I do not suspect software as (a:) a linux boot and winxp both present with the same issue and (b:) system stops responding to the keyboard(full system lock)


see http://www.asktheramguy.com/forums/showthread.php?t=66678 (corsair support forum)for a detailed account of the steps taken so far to clear the ram of fault.


aspire 5720-4643 intel p dual core t2310 w/ intel mobile graphic media accelerator x3100


Thank you for your time



Question Reference #080209-000031


Product Level 1: Notebook

Product Level 2: Aspire

Product Level 3: Aspire 5720Z

Date Created: 02/09/2008 04:50 AM

Last Updated: 02/11/2008 11:32 AM

Status: Solved

Operating System: Windows XP

Serial Number: ************************************ Date Purchased: 12/01/2007

Link to comment
Share on other sites

I was doing some swapping and trying to decide if I was going to give up and use one stick and try and sell the other stick to someone else and I ran across another configuration that fails. by having the 2 gig simm in slot1 and a 512 in slot2, I generate an identical failure. but a 512 in slot1 and the 2gig in slot2 tests ok. I can see two possible reasons for this.


#1 even though the rams do not match size, cpuid says they are running in dual channel mode if I have a 512 in slot1 and a 2gig in slot2. I was under the impression that dual channel mode required identical ram sticks( like a strip raid) when 512 in slot1 and 2gig in slot2, the chipset may be using the first 512 of the 2 gig and throwing away the rest(like a stripe raid) so when I put the 2gig in slot1 and it sees a only 512 in slot2, it can't run in dual channel mode and for some reason won't revert automatically to single channel mode and fails. this does not explain why 2 2gigs will not work though. I will do some testing to see if actually only 1 gig available in this configuration but I am currently on the road and unable to test properly.


#2 all the chips are 1.8v 4,4,4,12. however the 2gig has more chips than the 512 therfore it has a higher resistive load. a higher resistive load at the same voltage requires a higher amperage draw. slot1 is unable to supply sufficient amperage to power the 2 gig chip if slot2 is also drawing power and therfore trips a "circuit breaker" and crashes.


I may be talking out my *** as I really don't have a good grasp on the electrical engeneering aspects of computers and specs like amperage draw etc are not available to me about either the chipset or the ram. I would appreciate your thoughts on this matter as I would like to resolve this issue.


thank you for your time


ps I will also be reopening the "solved" acer problem and seeing what ram they will support in order to upgrade this machine to 4gig

Link to comment
Share on other sites

  • 10 months later...
  • 2 months later...

I had done the same as some people here.. swaps ram back and forth, slot 1, slot 2 .. 512 works in slot a with a 2 g in slot 2 but not the other way around.. the 2 2 gigs will not work together.. ect ect



What i found, and i have no idea why or how to fix it,

Is that i noticed when i looked at the ram.. along with all of the other descriptive numbers printed on that sticker was something that said (on the 512 ) was 2Rx16 ,,, hrmmm then i looked on the 3 different 2 gig sticks i had

all 3 said 2Rx8


My theory at that point was it will run a 2Rx8 in slot one,, but only if that is the only stick on ram in the whole machine..If you try to add a second stick.. boom no go.


So to test this theory,, when my bf got home i ripped open his acer, which came with 2 1 gig sticks unlike mine that came with 2 512's

Had a look and his 1 gig and they both said 2Rx16.


Plugged the 2Rx16 1 gig into slot 1 and 2Rx8 2 gig into slot 2 and sure enough, i was in business with 3 gigs of ram.


So i think if there is such a thing as 2 gig stick that says on it 2Rx16 and that it put in slot one with another 2 gig stick other either kind, In theory we should be all set..


And its only this machine, as my bf has an acer that looks just like this one, but its bigger and has 17 inch monitor ( thus a different model all together) but it takes both 2 gig sticks with the 2Rx8 and work just dandy

Link to comment
Share on other sites

  • Corsair Employees

There are a few things that can be done to try and make this work but a few things to do first and I am speaking in general terms because it looks like there are a few people having problems with this NB or the same make of NB but maybe a slightly different model.

1. Check with the NB Manufacturer to see if there is a BIOS update for your specific model.


2. If you have the latest BIOS remove all of the memory and turn on the NB, it should beep at you and then just turn it off. And install just one of our modules and see if there is an option in the NB BIOS setup called Load Setup Defaults and then test the system with one module.


If that does not solve the problem we can try replacing the modules if you like but if they work in another system like I think someone posted previously then for sure it is not the memory.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...