Jump to content
Corsair Community

Flash Voyager 16GB: USB Device Not Recognized


Recommended Posts

I just had this drive replaced (Case#384368) for not being recognized (it got to a point where not even Windows could detect its presence on the USB chain)


The replacement was brand-spanking new (I did a will-call rma and picked it up just a few weeks ago) and for a time, it was working perfectly.


But now, it doesn't want to be recognized at all....it would just cycle the "USB Device Not Recognized" message many times (it's like a loose connection).

I've tried several computers (a i915 based desktop, i915 based notebook, i965 based notebook, i815 based ol' school notebook, i815 based desktop, and a i975 based desktop). All the same result.


I've also tried different ports, hubs, powered hubs, etc.

(even though it's the only thing connected...it will still fail).


Unlike the first drive, it seemed to fail a lot quicker....could it be because this newer drive uses MLC? (The old one was a first gen, pre-GT version)

I don't mind having to replace it again (luckily, I have copies of the files that were on it so that's not an issue), but my concern is that it might happen again (that and the annoyance of it failing). :[pouts:

If necessary, I don't mind Corsair's engineers analyzing it, if it helps solve the problem in a future rev.


Are the GT's more reliable?

What about the Survivor line?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...