Jump to content
Corsair Community

MacBook--2GB of RAM not taking


Recommended Posts



I have a MacBook 1.83 intel core 2 duo...

I tried to install 2GB of RAM and it would not take. Upon startup the sleep light would blink rapidly with black screen... no responce.


I tried different slots for each, one at a time with old RAM in the other slot, exchanged the previous set for a new set just in case they were damaged.


I have tried almost everything.. any ideas would be great.



Link to comment
Share on other sites

  • Corsair Employees

On some laptops you will need to reset the configuration for the laptop to recognize the new hardware. Follow these steps: Please make sure when physically removing or installing hardware that the system is not plugged to the AC adapter and remove the battery. Power on the laptop with no RAM installed. Leave the system on for 30 seconds. Then install the new memory and power on.


If it still does not boot up correctly, test the modules one at a time.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...