Jump to content
Corsair Community

4x1GB in DFI Infinity 975X/G does not show > 3GB


Recommended Posts

I've been having some trouble getting a recently purchased second kit of XMS2 TwinX-2048-6400 RAM to work. I have already had one set working perfectly in the system for almost a year, and decided to add another kit to bring the total amount of RAM to 4GB (with all 4 slots filled).


When all four slots are filled only 2GB of RAM shows in any operating system (if I turn Memory Hole Remapping off it goes up to 3GB), yet the bios and memtest86 both report 4GB of RAM being present. There appears to be nothing wrong with the RAM as various combinations of the sticks in the DIMMS with less than 4 slots being filled checks out ok and all the RAM is reported.


The system is:

DFI Infinity 975X/G (Bios: 10/12/2007)

620W Corsair PSU

2xCorsair 6400 RAM kits (4x1GB)

E6600 CPU

2 Seagate SATA 320GB HD's

EVGA 8800 GTS 320


Creative X-Fi Platinum

Main OS: Windows XP Pro 32

Other OS'es: Gentoo Linux, Windows Vista Business (both 32bit)


After reading this post:



I tried upping the system voltages for the DRAM to 2V, but still no luck.


Furthermore I have tried:

Manually setting the RAM timings to 5-5-5-12-15

I couldn't find the command rate in the bios to set that (maybe it has another name?)

Slowing the RAM down to 667 (was running standard 800)

Swapping sticks around and removing them in various configurations

Updating the bios (now running the latest version)


Memtest86 (with hole remapping on) tests the ranges 108-2047 and 4096-6144 successfully with all four sticks in place. If I set it to test Bios-All (rather than Bios-Std) it fails in the late 3000's. It prints too quickly for me to catch where it starts failing.


Removing one stick from any DIMM (or turning memory remapping off) causes memtest86 to test the range 108-3071 - successfully. In both of these cases 3GB is reported in all Operating Systems.



Any help would be greatly appreciated, having 4GB usable would be fantastic so I when I get around to installing a 64-bit OS it will use it all.

Link to comment
Share on other sites

  • Corsair Employees
If the BIOS and memtest show all 4 GB then it is all being detected. This is a limitation with any X86 system running a 32-Bit Operating System. The system will only recognize 4.0 Gig Bit of memory Max (Not Giga-Byte) and the other memory in your system will come off of the top, like memory in your Video card and or the cache in your CPU and network card. So for example if you have 4x 1024MB modules, Windows will see minus the cache in your CPU and the memory in your Video card So if you have a 256 Meg Video card it might show 3.2 Giga Byte of total memory. And with some MB's they will reserve some of the memory for PCI devices in the system so that number may drop to bellow 3.0 Gig of total memory. For a more detailed explanation, please refer to this Microsoft Knowledge Base Artice: http://support.microsoft.com/kb/929605/en-us.
Link to comment
Share on other sites

Yes I am aware of the addressing issue with Microsoft Windows. What I don't understand is that it drops the amount of RAM being detected (down to 2GB) after I add the fourth stick - even if it is not addressing all of it, the amount of memory should still go up (slightly) when I add the fourth stick.


What I'm wondering is if it could be a motherboard incompatibility - with the fourth stick of RAM it stop addressing it in one continuous block, it addresses it with 108-2047 then a gap, then 4096-6144. The operating systems perhaps all need one continuous block?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...