Jump to content
Corsair Community

Memtest86 - Faulty RAM?


Recommended Posts

Hi there!


Occasionally when I open event viewer in Vista Home Premium to make sure my new build system (about 1 month old now!) is working ok, I notice 2 errors always occurring when the computer is first booted. One is an http ssl error that I have been unable to identify - the other is variations on the following memory error:


Machine Check Event reported is a fatal memory hierarchy error.

Trasaction Type: 2

Memory Hierarchy Level: 2

Request Type: 0

Address: 2145688580


So, to be safe I downloaded memtest86 to a CD and booted from it to test out my RAM, leaving it running overnight. This morning, the following errors had occurred after about 30 passes:


Tst Pass Failing Address Good Bad Err-Bits Count Chan

5 9 0006cb356f0 1739.3MB 00010000 00000000 00010000 1

5 9 0006db356d0 1755.3MB 00010000 00000000 00010000 1

7 19 0000a0920ec 160.1MB cde8a2b5 cdc8a2b5 00200000 1

7 24 000619dc0ec 1561.7MB afe44594 9fc44594 00200000 1


I should add that I have had no obvious issues or problems in Windows aside from the Crysis demo crashing once. My wifi-ap driver had some issues but I managed to resolve those myself by completely removing it, then reinstalling it, so I suspect that was because of a driver conflict.


My RAM is the TwinX 2GB DDR2 8500D matched pair (2 x 1GB), and my mobo is the Asus P5K Premium Wi-fi AP. The motherboard used default settings for my RAM - I haven't checked those but since this RAM is supposed to be high quality and overclockable, I wouldn't have thought the default settings would stress it too much!?


So, are these errors acceptable, or should I get an RMA and return the RAM? Alternatively, is there any further testing I should do beforehand? Many thanks :)

Link to comment
Share on other sites

hi wired, thanks for the advice! i'll use those settings and try running memtest overnight again to see what happens - i must admit after having browsed this forum, it seems that having higher voltage settings fixes many peoples problems! just one more thing if i may - is it worth setting the speed to 1066mhz, or should i leave it at 800mhz? many thanks.
Link to comment
Share on other sites

  • Corsair Employees
Along with Wired's settings, I would suggest testing at 1066MHz. Also make sure to test the modules one at a time. If both modules fail individually there may be some other issue, however if one fails and the other passes, then we will want to get them both replaced for you.
Link to comment
Share on other sites

Thanks for the advice folks. I think using those settings may have worked - I set the RAM at 1064MHz, and manually set the timings to 5-5-5-15, 2T, at 2.0V - I figured I'd try the higher speed first and use a slightly more conservative voltage just in case I could get away with it.


After leaving the PC running memtest overnight, it managed 20 passes over 7 hours with no errors. I've left it running today whilst I'm at work so I can be absolutely sure the new settings are stable, but it looks good so far. I'll post a new reply tonight with the end results.


Thanks again!

Link to comment
Share on other sites

Just to confirm, after getting back from work this evening memtest had been running for around 18 hours/60 passes with no errors. I think I can assume that means the new settings have definitely worked! Thanks again for all your help.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...