Jump to content
Corsair Community

Need help with RAM mistake!


Recommended Posts

I purchased a pretty intense gaming almost a year ago and had very little problems until Nov. of last year, when I decided to add more ram. I accidentally purchased the wrong ram latency to match my original ram, and now my computer is chock full of problems.


I started out with 2 GB TWIN2X2048-6400C4 at 4-4-4-12. I never had any real issues with my setup and I routinely played Battlefield 2 with little to no difficulty. I then purchased what I thought was the same ram but it turns out I received 5-5-5-18. I installed it without noticing, and then the problems began.


It started with Audio issues where the sound in BF2 would crack up and lag, and even when the game was shut down, WMP 10 would still lag and crack up until I restarted. Tried updating every driver I could find, GPU, sound card, etc. and also flashed the BIOS. It only got worse. I tried using just 3 GB of ram, switched the new sticks one at a time, then tried to just go back to the original 2 GB, but the damage to the system seemed to have been already done. BSOD's all over the place, Crash to desktop from BF2, or audio/lag issues galore!


I recently noticed the two different latency settings and I am wondering if I may have actually damaged the original RAM from my system by mixing and matching. Is that possible? Actually, now that I look at my Tigerdirect invoice, I think the mistake may actually be Corsair's. The UPC code on the product I was sent says it is supposed to be 6400C4, but I think the package actually contained 6400.


I actually got to the point where my comp would no longer boot with the original RAM! I am now able to run the comp with only the new ram, which is the plain 6400 at 5-5-5-18, but it still has problems with running BF2.


I really need some help here. I am more of a software type guy than a hardware/setup kinda guy, so a lot of this is new to me, but I pick up relatively quickly. I am pretty upset that my goal of upgrading my RAM has ultimately thrown a wrench into what was a pretty stable system, and now that I look into it further, it looks like the mistake was not entirely my own!


Please advise, as I am really at my wits end and cannot figure out this puzzle. Thanks for the help!

Link to comment
Share on other sites

  • Corsair Employees
With 4 modules with this MB the memory frequency should be set to DDR667 and I would suggest resetting the BIOS with just one of the opld modules and then load setup defaults and set the tested settings and Voltage and test them one at a time with http://www.memtest.org and make sure that you disable legacy USB when running any memory test on that MB.
Link to comment
Share on other sites

I did as you suggested and tried each individual stick of the original memory for my computer. The first stick I tried must be fried, because it would not even get to the BIOS setup screen and the computer just perpetually beeped. I tried the second stick in the same MB slot, ran memtest v1.70, and it returned 2048 errors, so it looks like the original memory sticks are no good. This is odd because they were completely fine and the system ran very stable up until I installed the two new sticks I received and now they are both defective and the new sticks seem fine, because I re-installed the two new sticks and ran memtest and after multiple passes there were no errors found. Also, in memtest v1.70, I did not see anywhere that there was anything about a "legacy" mode.


Please keep in mind that I believe that Corsair actually sent me the 6400 RAM sticks in error, instead of the 6400C4, but now it seems that only the 6400's are working. Is there a way to RMA the two bad sticks (6400C4) for two more of the same type as the working sticks (6400) so that I have four matched sticks?


What do I do now?


Thanks for your help!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...