Jump to content
Corsair Community

Failed Delay Write !


Recommended Posts

Hi Folks,


My solution to "Failed Delay Write" for Corsair Voyager GT 8GB.


Symptoms first:

When i first get my Voyager GT, it was working fine, all of a sudden i realized that it was giving "Failed Delay Write" in Win XP when transferring some of the files. Looking further, i noticed that only some of the files are causing that error when transferring from the PC to the voyager. Regardless of the file size, it was not possible to copy or move some certain files, copy is OK up to some point, and then "BANG" it stops and gives "Failed Delay Write" and "The system cannot find the file or folder..." and then the system disconnects the voyager.


First thought the voyager was defective. However, when i try it on some other PC, everything was fine!?


Then i realized that the problem is not only with the voyager but also for the external USB harddisk that i have. The odd thing is that this Harddisk was OK for over 1,5 years, but all of a sudden i started receiving "Failed Delay Write" from this too! Weird...


Realizing that the problem is not with the voyager or the harddisk itself, i had to do something with this specific PC. Googled, tried everything (registry, BIOS update, changed RAM etc.) nothing solved it.


Thinking "What have i done in the past 2-3 months related to the USB ports on my PC?" i remembered that i uninstalled WIDCOMM Bluetooth drivers since i changed my Cellphone and WIDCOMM was not compatible with it. Bluetooth dongle was laying around not plugged in. I thought "Maybe the USB drivers are corrupted during uninstall" since i knew that disabling Microsoft Bluetooth stack drivers and installing WIDCOMM was a pain in the a.. After uninstalling WIDCOMM, i remembered spending some time to get Microsoft Bluetooth stack drivers up, but was unsuccesfull.


So i installed WIDCOMM back, and plugged in Bluetooth USB dongle, then i see that WinXP sees the dongle as Microsoft Bluetooth stack again. Voila, i uninstalled WIDCOMM again.


Surprisingly, installing and uninstalling WIDCOMM seems to fix something back again with the USB drivers, cause i'm not getting any "Failed Delay Write" after all. It seems to me that the USB drivers we installed or uninstalled in the past may left some residue, which affects file transfers, even though that all USB connections seems working fine.


Hope it will also work for you...


Anyway, then they all lived happily ever after...



Link to comment
Share on other sites

  • 4 months later...

I also get the "Write Delay Failed" error on my 16G Flash Voayager. I tried it on other PCs and sometimes I get the same error. It rarely happens but it's annoying. I also cannot delete, rename or move some files from the flash although I safely removed the stick when I created the file.


I thought my flash is deffective but since the errors don't ocurre so often it's not worth the hassle of replacing it from the online store I bought it from.


I tested the read/write speed with Check Flash 1.03 several times and I get around 12 errors in a complete cycle.


Any benchmarks I should test my flash drive with before I know for certain that is deffective?




----- later edit ------


OK, so I downloaded HDbench 3.40 beta6 and tested my Flash Voyager (non GT).

I got this:

Read: 22520

Write: 7693

RRead: 21566

RWrite: 2029


(100MB test FAT32 formatted on WinXP sp2)

I know that the read/write speeds are computer-related, but should I be worried with a 7 MB write and 2 MB random write rate?


same test, same PC, no-name (Platinum) 2GB flash:

Read: 12303

Write: 1605

RRead: 11915

RWrite: 588

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...