Jump to content
Corsair Community

TWIN2X2048-6400C4 boot problem


Recommended Posts

Hi all.

One year ago I got a couple of DDR2 TWIN2X2048-6400C4.

Since then I used them whithout any problems with a M2N-SLI Deluxe

motherboard by Asus and an AMD Athlon 4600X2 CPU.

Three days ago the PC suddenly stucked and didn't boot up (post) again.

Investigating about the problem, I discovered that one of the two memory

stick prevented PC from booting up correctly. The other memory module

worked fine. I tried to put the wrong module in every memory slot available,

but I got the same problem.

I tried to upgrade motherboard bios without success.

I say it again: both modules worked fine for more than one year without problems and my hardware configuration didn't ever change.

Please, do you have any more suggestions?

Thanks in advance for your reply.

Best regards


Link to comment
Share on other sites

Thank you for reply.

Unfortunately I cannot setup any bios settings because PC doesn't

execute POST if memory stick is installed: I got only a black screen

and PC doesn't boot up.

I'll compile the RMA request form.

Best regards


Link to comment
Share on other sites

  • 3 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...