Jump to content
Corsair Community

BIOS settings to run 4 Gigs of TWIN2X2048-8888C4DF

Recommended Posts

Has anyone been able to get 4 gigs of TWIN2X2048-8888C4DF running on a 680sli m/b? If so could you please let me know what BIOS settings you used?


From what I understand the MCH comes under a lot of stress with the ram modules and as a consequence the voltage needs to be adjusted for the NB and maybe the ram as well (?)


Any help would be much appreciated!


Vista 64

EVGA 122-CK-NF68 680i SLI

TWIN2X2048-8888C4DF x 2# (4gigs)

XFX 8800 Ultra x 2# SLi mode

Antec True Power Quattro (1,000W)

Link to comment
Share on other sites

I've tried running them at 800MHz with (and without) an extra 0.05volts for the ram, it does not work. Nor does increasing the voltage on the NB. The system will run, but I get the bsod and tdr's.


I'm at the stage where running 4 gigs of ram is just not worth the hassle. As far as I can tell this is a problem with the memory control hub on the m/b. The m/b just can't seem to handle the ram speed. :confused:


The 780i m/b apparently has the same memory control hub as the 680i m/b so even on a new platform it would not solve my problem, or am I just missing something?


If anyone has got 4 gigs of this ram module running without problems please let me know.

Link to comment
Share on other sites

Guys, I've tried everything. Vista SP1, beta Nvidia drivers you name it. I've tested the ram and all is ok. I've concluded that this is not software. The only hope seems to be a tweak with voltages, but I don't really want to experiment (more than I have already) and burn anything out.


I don't think you can run 4 of these sticks and my guess is the m/b memory controller can't hack it. :confused:

Link to comment
Share on other sites

I have just about the same setup as you and my RAM is running great!

BIOS settings are 5,5,5,15 2T 2.15V 1066MHz FSB


It sounds like you might have a bad Stick of RAM. Have you tried pulling it all and try booting one Stick at a Time?

I know the 680i Chipset is a little dated and nVidia has updated some things on the M/Board. You might have the older version. If that's the case then you should be able to get another free of charge. EVGA I know will replace the older version of the 680i 122-CK-NF68.


Also, have you updated the BIOS? I know that flashing the BIOS to a newer version can be a hassle but it really helped the stability of my M/Board.


Hope this helps.


P.S. I looked at your system specs and noticed you have Raptors as well. Have you had any issues with SATA drive detection?

That's been a big headache with mine and I just can't seem to track down why it acts like it does.

I don't have mine in a RAID config because I like to keep the drives seperate, I'm an old timer, LOL!

It just seems like SATA, having no jumpers for master/slave drive must blow somethings Mind during bootup.

I do notice that all the drives are labled as master drives which makes my Heat tilt to the side like a Puppy hearing an odd noise... :O)

Link to comment
Share on other sites

  • 2 years later...
i seen your post about the hard drives they are showing up as all master cause you formatted them to that if you use the westeren digital tools you can set your boot as master then the others you set as slaves i have 5 westeren digital drives in my pc and they are all set 1 master and 4 slaves just to help you out see if that helps you
Link to comment
Share on other sites

  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...