Jump to content
Corsair Community

Autorun.INF Problem


nocr

Recommended Posts

Main Problem = I unable to create/maintain an autorun.inf file on my flash drive.

 

Background = I have had a problem with my previous drive, a 4GB Flash Voyager GT, which I had to send in to be replaced after it failed.

 

So I got a brand-new replacement, of the same model in the mail yesterday. Yay.

I plug it in, format it, and then transfer my backed-up data onto it. The data transfer seemed to take significantly longer than on my previous drive, but I didn't think much of it.

 

Then I tried to save a new autorun.inf file to the drive root, and MS Notepad said that one already existed, with read-only attributes. When I checked, I was unable to find one in WinExplorer (hidden files were being shown)

 

I saved the new autorun file in another folder, and tried to move it to the root. Windows Explorer prompted me to ask if I wanted to overwrite the existing file, which it said was 260 kb. (This struck me as odd, since a notepad file only a few lines long shouldn't take up that much disk space.)

 

so I clicked yes, and it pasted my new autorun file to the root. however, approximately 30 seconds later, it dissappeared.

 

 

Also, whenever I plug my drive in, dmadmin.exe runs. I don't recall this happining with my previous drive.

 

So far, I think that this dmadmin.exe is protecting this file. In fact, I had to terminate it in order to format the drive in the first place.

 

Anyone know how I can resolve this? I'm tired of having problems with my flash drive.

Link to comment
Share on other sites

Windows XP, and yes, I have used it successfully o multiple other drives.

 

Autorun.inf is just a simple text-based configuration file that can be configured to, upon drive insertion, tell the operating system which executable to start, which icon to use to represent the drive, and which additional menu commands to make available..
More Info

 

A sample contents of an autorun.inf file would look like this:

[autorun]
icon=my_custom_drive_icon.ico
label=nocr's flash drive
open=example_program.exe

 

that's essentially all there is to an autorun.inf file.

 

to create one, I'd just open up MS Notepad, and type up the what you see above.

 

Typically, a file like that would take up a kilobyte, at best. This is why I was surprised when windows told me that the existing autorun.inf file was 260 kb.

 

 

If there's any more info you need please don't hesitate to ask.

Link to comment
Share on other sites

Oh, ok. haha

 

I had kinda thought it was a little strange that you were asking that.

 

anyways, mine looks like:

 

[autorun]
label=nDrive
icon=nDrive.ico
open=PStart.exe
action=Start Driving
shell\lost=Return Drive to Nick
shell\lost\command=\PortableApps\Lost.exe

Link to comment
Share on other sites

No, and No.

Yes, the drive shows up in My computer without my Autorun file on it.

 

Unfortunately, this is now the least of my worries. Last night, while I was on the computer, the drive failed. It failed in a way similar to the way my previous drive had, where the content's just disappeared.

 

However, this time, when I later plugged it into another computer, and tried to open a word document, the document opened, but was full of characters which looked like:

[]

but without the break in the middle.

 

I am currently using a 512 MB SanDisk Cruzar Micro flash drive, (which I have been using for over 3 years with no problems), as my backup.

 

Why does this problem keep occurring?

 

This is becoming extremely frustrating ordeal for me, and I'm looking forward to some sort of resolution.

Link to comment
Share on other sites

  • Corsair Employees

Not quite sure why this is happening, can you try and format the drive from a command Prompt and then see if it will work?

Please try to format the drive from a command prompt with this syntax:

Format (X:) /FS:FAT32 /U (X=the drive letter assigned to the Flash Voyager)

If you still have problems we can get it or them replaced, please use the RMA request found in TSXpress or follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it!

Link to comment
Share on other sites

Ok, I'll try reformatting it.

 

However, if I do send it in, is there a way I can actually get someone to look at it and try to determine what is happening? This is the second time this has happened, and I would like to get some more definite answers

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...