Jump to content
Corsair Community

16GB Voyager appearing as "file" not drive


Recommended Posts

My new 16GB card does not appear to work for some reason. I have tried to use on 4 different xp machines.... it seems to install fine, however when I double click on the drive icon (it has a unique drive letter) I get the dialogue to choose which application to open this file "I:\" instead of opening a window. I have tried all USB ports on all of the machines with and without a hub. I have uninstalled, reinstalled, restarted etc etc but same issue. I get the usual request of what to do when I insert the drive... If I open as a window then, it opens up as normal. If I closer this and then try to re-open - no luck.


What's strange tho is that dragging a file icon over the drive icon actually copies the file to the drive, I can save a file from an application onto the drive, I can even open up windows explorer then navigate to the drive and copy files and see the content.


This seems crazy - I have never seen this before with a flash drive. Any idea what this is and whether it can be fixed or does this need to be RMA'd.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...