Jump to content
Corsair Community

Flash Voyager 8GB - now only 4GB?


Recommended Posts

Hi all,


My 8GB Flash Voyager got corrupted a few weeks ago. I have no idea how but basically it just ended with gobbledegook on it.


I tried repairing using OS X Disk Utility and it sat there repairing errors for about 30mins then hung.


I then reformatted it on the Mac and it looked OK. Took it to a Windows machine to get a file - file looked like it copied OK but when I plugged it into the next Windows machine there was nothing on it.


Tried reformatting in Windows and it is now showing up as only 4GB.


Took it back to the Mac and used Disk Uitlity again to repartition it and was able to make an 8GB partitition. Then tried to write zeros to whole drive and it hung about halfway through.


Now it show 4GB on Mac and Windows...


I assume the drive is going to need to be replaced but I wanted to check if there is anything else I can try before sending it back (again - this is already a replacement).




Adrian Smith

Centenary Institute, Sydney, Australia

Link to comment
Share on other sites



Haven't had access to a machine that can boot Win98 over the weekend. However, I did run FDisk from Unix (Mac OS X 10.5) and was able to initialise the MBR sector.


After doing this I was able to re-partition it to 8GB. Was also able to write zeros to the whole disk without error.


However, the next time I plugged it back in it had gone back to 4GB :(


So, I guess it is looking like I'll need a replacement?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...