Jump to content
Corsair Community

16GB Voyager Trouble


Recommended Posts

I have a 16GB drive that has been sporadically not recognized by multiple PCs. 90% of the time when inserted, it comes up as "Removable Disk" in Windows XP SP2. When clicking on "Removable Disk", Windows says the drive is not formatted and asks if I would like to format the drive. I was lucky enough to get everything off the drive before now.


I have tried formatting through Windows, through the DOS commands listed in the forum and this thing just does not want to work.


I shouldn't have to spend hours trying to get something to work that has a 10 year warranty on it just to have to yet again send it back for another drive that will probably fail. I should not be wasting my time on making this work. This thing should just work. This is the second of these drives that has gone south on me. I will NEVER EVER purchase another Corsair drive. This is ridiculous. I could see one going bad, but two? Give me a break.


Its really too bad because when it works, they are great. But I have to find something more reliable. This is truly disappointing and I don't know if there is a way Corsair can change my mind on that.

Link to comment
Share on other sites

Like I said in my original message, I have gone through all the formatting options on this site. In fact I read through other posts and tried all I could find before posting.


I do not believe this is a hardware issue on my part. I have had a SanDisk Titanium drive for 2 years and used that one on the same exact systems with ZERO issues. This is the fault of the Corsair drives.


I have used/tried them on a Dell GX240, Dell GX280, 2 Compaqs and my Sony Viao. It does the exact same thing on all the systems I have tried it on. Again, my Titanium does fine, so this is a faulty drive.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...