Jump to content
Corsair Community

connection problem


Recommended Posts

I have a 8GB flash voyager.

It seems to have problems connecting properly with usb-ports;

In my older pc (4 years old usb 2.0) I have two usb-ports at the front, in one of these the voyager will not connect, in the other usb-port it will, but disconnects within a minute every time I try..


I've also tried the voyager on my new pc and at the usb-ports at the back of my old pc. (which are used less) Here it works better, but still disconnects every few days.


Trying on a friends old pc, (5 years old usb 1.0) it worked on one port, but did not connect to an other.


The front usb-ports on my old pc might be worn a bit, but they both work perfect with my WD external hard drive, and usb-telephone..

I also fear that that the voyager will not work properly any more on my new pc as the usb-ports start to wear..


Is connecting poorly to older usb-ports a known problem for the voyager, or might I expect an other one to work better?


I could return it to my reseller, but they only replace parts which don't work when they've tested it. My voyager will probably work fine when they test it on a new usb-port...

Link to comment
Share on other sites

  • Corsair Employees
Based on what you have posted I would suggest using an externally powered USB HUB. Many older systems will not be able top provide enough power for a device like this and they would need to provide 500 MAmps. But please test the drive in a known working system to be sure.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...