Jump to content
Corsair Community

Vista Driver? Other Flash Drives Work


Recommended Posts

I just bought a CMFUSB2.0-4GB and a CMFUSB2.0-16GB Voyager flash drives and Vista 64 Ultimate is not installing the driver. I have tried C:\Windows, C:\Windows\drivers and so on and I cannot get the drives to work. I have a 2GB by another brand and it works like a charm, as well as a 512MB (by another brands also).


I tried rebooting with the drive left in and it found it and so on but I get the Install Hardware prompt. I tried the drives at work and they work fine on our tech computer (XP Pro 32). I have all the updated drivers for my machine.


I tried removing the USB root hub and rebooting and such, no luck.


I have 4GB of XMS2 gaming memory I bought just for Vista 64. I have no intention of going back to XP Home 32 just to get my flash drives to work.

Link to comment
Share on other sites

Hmmmm, found a thread on an MS.com and did this:


  1. Connected the flash drives
  2. Clicked CANCEL on driver wizard install
  3. Rebooted
  4. After reboot I clicked CANCEL again on driver wizard




The drives appear fine. I assigned custom drive paths and formatted them after the path assignment so I know it's them and not my HDDs/DVD-RW.


Also after I rebooted a few times the driver wizard dialog appears but I canceled the wizard, seems Ultimate 64 wants a driver but the drives work like CHAMPS! I'm using the 4GB for Readyboost and the 16GB for backup/storage.

Link to comment
Share on other sites

  • Corsair Employees

Thank you for posting that, as it will help others with the same problem.


Edit if you are having this problem, it appears that its happening with other flash drives as well

Which you can see from this link:


Note that Windows Vista does not require any drivers for any of our Flash Drives.


1. Insert drive and wait for about 20 seconds to see if the driver installation is slow.


2. During device driver search, point to a location Windows\System32\DriverStore\FileRepository and enable “Include subfolders” in the Browse window.


If this fails, point to one of the subfolders within FileRepository:










3. If FileRepository location(s) doesn’t work, point to location Windows\System32\Spool\Drivers and enable “Include subfolders” in the Browse window.


4. Check Device Manager for incorrectly installed drivers for the Flash Voyager; uninstall them and reinsert the drive.


I tried all this and still no success. Each time Vista reported “The system cannot find the file specified”.


After searching the web for a couple of frustrating hours I cam across this entry by WickedMX…


I’ve been experiencing the same problem with usb storage devices for the last few weeks and have visited numerous forums discussing it. After having no joy I decided to take a look around my system folders and have now got these devices working again. While looking around I discovered 2 points of interest:



In C:\Windows\System32\DriverStore\FileRepository I had two folders named “usbstor.inf” but each one had a different set of numbers attached to the end of the folder name. - could this be where part of the problem lies?

When I looked in my C:\Windows\inf folder I discovered the usbstor.inf and usb stor.pnf files were missing - this definitely had to be an issue.

Once I discovered these anomalies, I proceeded to copy the pnf and inf files from the most recently updated usbstor.inf folder to C:\Windows\inf. I then went back to the update driver wizard, pointed to the inf folder and what do you know but they all started working again.



So with some scepticism I tried this approach and it worked.


Bottom line this is a Microsoft Problem and they need to address it!

However, if you have this problem we will be happy to help you.

Link to comment
Share on other sites

  • 2 months later...

Once again, Thanks RAMGUY!!! I tried number 4 from the list above and its working as it should!!! Had the problem over Windows Vista x64 but all is as it should be.


Im not just saying this because i use Corsair but your support is always second to none!


Thanks RAMGUY and Corsair! :D:

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...