Jump to content
Corsair Community

TWIN2X2048-6400 G problem with GA965P-DQ6


Recommended Posts

Dear support,

I'm setting up a new system and I've plugged in two kits of the same type (TWIN2X2048-6400 G). However if I try to install Suse Linux Enterprise Server 64bit or if I try to just run a live CD of Knoppix, the system will reboot before the OS comes up.


Now the strange thing:

3 Memory modules work in Flex mode (independent of which memory modules I use)


2 Memory modules work in dual channel mode


As soon as I plug in module number 4, the problem occurs. I upgraded to the latest bios version (including the recommended set to optimized defaults) and I ran Memtest86 while all 4 modules were plugged in (no error is reported). Do I have to change the voltage or something on the timing?


Thank you so much in advance!

Best regards,


Link to comment
Share on other sites

First of all - thank you very much for the quick answer!

I selected +0.300V for the DDR2 OverVoltage Control and I've set SPD to 2.50 which displays me now 667 MHz for the Memory Frequency. This is what you wanted me to do, right? The system still hangs while booting.


BTW I also tested meanwhile using just bank 2 & 4 to make sure that bank 4 is not broken on the mainboard. It worked in that setup.


Is there anything else I can do? Thank you so much in advance!

Best regards,


Link to comment
Share on other sites

Thanks again - the problem is solved. However it has nothing to do with the memory - as you expected. In case someone has the same problem as I do I want to add some info here:



Linux will stop somewhere during the booting process. If you look at a console, it will show a line like


agpgart: Detected an Intel 965G Chipset.


... and then it will stop to continue or even reboot the system.


When does the compatibility issue happen:

Linux Kernel 2.6.x (not sure which subversions are an issue).

Mainboard using the Intel 965G chip, such as in my case the GIGABYTE 965P-DQ6 (Rev. 2.0)

Using >= 4GB of ram - no matter if it's corsair or another memory - it's just the amount of total memory which causes this issue.

Probably this issue happens only for the 64bit mode - not sure (I'm using the AMD64 architecture)


What can you do:

Start Linux with the kernel parameter mem=4096M. You can enter this in GRUB for the line which starts with "kernel". Edit it by pressing the e key while in the OS selection and navigate to the kernel line - press e again.

The line needs to look similar to that including the mem option:


kernel /vmlinuz-2.6.15-5-amd64 root=/dev/md0 ro mem=4096M


Hopefully there will soon be a fix for this module. It's the intel_agp module which is broken. However you can at least start linux then.


See also these links to get additional information for this issue:




And again - thank you so much for the fast and competent help here which just proved that corsair was the right choice :biggrin:

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...