Jump to content
Corsair Community

Memtest86+ 1.70 reporting errors on 4GB of TWIN2X2048-6400C4


Recommended Posts

So I bought two packs (4 1GB sticks) for TWIN2X2048-6400C4 from newegg to use with my Asus P5K board and Intel Core 2 Duo E6750 2.66GHz processor..


I have set the timings to 4-4-4-12, with 800MHz DRAM speed and 2.1V to the DRAM.


By themselves, the modules test fine.

In single pairs, the modules test fine.

They test fine in either channel.

When I put all four modules in, I get errors. Sometimes in low ranges, but what throws me off is that I'm getting errors in the 4900MB range...?


I should mention this also occurred with an Abit IP35 Pro motherboard.



I've been fighting with slow data corruption that really looks like the RAM, but I fail to understand how I can get the same error when having all 4 sticks in on two different motherboards - and that all these sticks test fine singularly, and when paired.


I'm hoping that someone out there knows that this is either a known bug with Memtest86+, or can tell me what's going on, or suggest new timings/settings withing the American Megatrends BIOS that I can try...


Help! :D


EDIT: Should also note that I'm running Vista64 off 2GB in dual channel right now, and everything appears to be fine. I'm slightly nervous about putting the other 2GB in until I hear back. (Been at this for a few days now, nice to have a working system...)


EDIT EDIT: Put the other 2GB in, and got CRC errors trying to install Oblivion. :( Definitely an issue.


EDIT EDIT EDIT: A little searching, and I read that on some Asus boards, you need to clock down to 667, but I still get the same errors in memtest.

Link to comment
Share on other sites

I installed with 2GB, and then applied that patch before going to 4GB. My problem is that MemTest86+ is still showing memory errors that are out of range, even though the sticks test fine in pairs.


I can put all 4 sticks in, and get CRC errors when copying files off DVDs....

Link to comment
Share on other sites

  • Corsair Employees

Load Setup Defaults in the BIOS


Set memory voltage to 2.1v


Set NBvCore to 1.4v


Set the following timings:

tCL = 4

tRCD = 4

tRP = 4

tRAS = 12

Command Rate = 2T

tRC = 24


Let me know if you are still having issues!

Link to comment
Share on other sites

Still no good. I tried those timings @ 667MHz, and got errors.


It seems to consistently fail on Test 7. Not sure if that means anything, the addresses are all different. I've tried multiple settings of the timings, multiple voltages, combinations of letting the mobo determine timings with the voltages set manually, all auto @2.1V, 800MHz, 667MHz, nothing seems to behave correctly. I've tried 5-5-5-18 timings, 5-5-5-15, I've re-flashed the BIOS, I've moved modules around....turned off legacy USB....lots of voodoo here.....


I'm really unsure where to go now. I'm not trying to overclock a thing, shouldn't the setting in SPD be sufficiently relaxed to make it all work? I get better results with 2.1v, but it's not error free. I think I've only seen it pass test 7 once, and that was then followed by other test 7 passes with errors.


The only time I get no errors is when running two modules. Maybe I should just return these modules and go with 2 2048MB modules. What am I missing here, I get worse results when running more relaxed, SPD-determined timings on memory rated for much tighter??? That makes no sense.

Link to comment
Share on other sites

Tried bumping the voltage from 1.40 to 1.55, which was the next setting. Got errors right off the bat.


What confuses me is that I can run this memory at conservative speeds, and actually get much worse results than if I were to run it at 800MHz and very tight.


For the record, here's the current settings and some ranges. This seems to be the most stable setting, though as of this writing, I have 21 errors at 7% into test 7.:


FSB Strap to North Bridge: Auto

FSB Frequency: 333

PCIE Frequency: Auto

DRAM Frequency: DDR2-667MHz

DRAM Command Rate: Auto

DRAM Timing Control: Manual

CAS# Latency: 4 (3 to 6)

RAS# to CAS# Latency: 4 (3 to 10)

RAS# Precharge: 4 (3 to 10)

RAS# Active Time: 12 (3 to 34)

RAS# to RAS# Delay: Auto (1 to 15)

Row Refresh ACycle Time: Auto (20,25,30,35,42)

Write Recovery Time: Auto (1 to 15)

Write to Read Delay: Auto (1 to 15)

Read to Precharge Time: Auto (1 to 15)

DRAM Static Read Control: Auto


CPU Voltage: Auto

CPU Voltage Reference: Auto

SPU Voltage Damper: Auto

DRAM Voltage: 2.10V (1.8V to 2.55V, .5V increments)

FSB Termination Voltage: Auto (1.20V to 1.50V, .10V increments)

North Bridge Voltage: 1.40V (1.25V, 1.40V, 1.55V, 1.70V)

North Bridge Voltage Reference: Auto (0.67x 0.61x)

Link to comment
Share on other sites

4 X 1024 is sometimes a real crapshoot. The same model of motherboard can accept them and the next one refuse them. I advise all those purchasing DRAM and who want 4GB to move to 2 X 2048 and a 64bit OS.


Proof that the problem is the mainboard's inability to run with all four banks populated is:

By themselves, the modules test fine.

In single pairs, the modules test fine.

They test fine in either channel.


My advice? Sell or return these 4 modules, purchase 2 X 2048 and be done with all the time spent. There comes a time when it is completely diminishing returns and you are there. I personally am not willing to waste my time trouble-shooting for great lengths of time. I move quite quickly to finding a solution that works and not trouble-shooting.

Link to comment
Share on other sites

  • Corsair Employees
And with 4 modules DDR667 would be suggested and be sure to set the memory Voltage to 2.1 Volts and I would set the NB/MCH Voltage to +.05 Volts as well. And you need to get the latest BIOS with that CPU and load setup defaults and then set the settings.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...