Jump to content
Corsair Community

memtest error

Recommended Posts

I did a memtest and got the following error

Memtest detected that (Random #) does not store values accurately. You need to fix this. I ran the test to 750% and the same message came up four times. I was only able to do 770MB during the test.

My bios settings for the D975XBX2 board are as follows for memory



tCL =5

tRCD =5

tRP =5

tRASmin =18

A channel = 5.0-4-4-18

B Channel = 5.0-4-4-18




Yes they are Corsair memory sticks, but I cannot locate the exact model number. They were bought as a pair 6 months ago. I am praying it is not the sticks.

My CPU is a E6600 Intel 2.4G

I find when playing Oblivion I get some crashes, and twice my system restarted on its own while playing


Where do I go from here? I get the error but unsure what to do to remedy the problem.


Link to comment
Share on other sites

  • Corsair Employees
Can you tell me our modules part# (How To Read the Memory Label) and please make sure that you have the latest Bios version and then load setup/optimized defaults and set the Dim Voltage to 2.0 volts (+.2 Volts W/Giga-Byte) and then set the timings manually to the tested settings for the specific module you have, or if you have Value Select "BY SPD" and then test the module/'s one at a time with http://www.memtest.org! If you still get errors, please follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it! However, if you get errors with both modules that would suggest some other problem and I would test them in another system or MB to be sure. In addition, with some MB's (Mostly ASUS) you have to disable legacy USB in the bios when running any memory test.
Link to comment
Share on other sites

I sinecerely thank you for your reply.

The Bios may be a bit outdated, I have BX97520J.86A 2212

The latest one is BX97520J.86A 2792 with many updates in between. Both MB and Ram are about 6 months old.

Here is what I have done so far:

Put it in manual

Raised the voltage from 1.84 to 1.96V (Just being conservative)

change tRCD and tRP from 5 to 4 (My only options are 2,3,4,5) to match channel A and B


Keep in mind that i am not able to change the values where it says Channel A and B =5.0-4-4-18. It is just displayed there. The value in CPU-Z SPD tab reads '5-5-5-18 for what that is worth. cpu-z Did tell me my ram model # CM2x1024 6400.

I have not done the memtest yet after these changes, but when my significant other leaves the house for a while I will try it again.

Any comments?

Thanks again

Link to comment
Share on other sites

i booted up today after the changes for the first time

First time My monitor showed nothing so I booted again.

I got to windows and ran oblivion and got the BSOD and it shut down and restarted on its own.

I changed 5.0-4-4-18 back to 5.0-5-5-18 and left the voltage at 1.96V

I am running memtest now and got an error at 655%. Yesterday I had 4 errors in the same amount of time

I am at 830% and just the one error.

I wonder if I bump the voltage just a little bit more say like about .4 Volts that the ram will run better.

Have not yet updated the bios but have the program on my desktop.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...