Jump to content
Corsair Community

4GB Flash Voyager - USB2


Recommended Posts

Hi, I have the exact same problem with my 4GB Flash Voyager. I found this thread with google.


Is there any way this problem can be solved by the end user because I'm in Ireland and would prefer not to have to wait for the long shipping and return process to the states.


Also, if an RMA is necessary I'm not sure what the part number is for a Flash Voyager 4GB.


Thank you for your help.

Link to comment
Share on other sites

Sorry I must've created my original thread badly. I meant to post it as a follow on to this post. This guy has exactly the same issue as I have (also summarised below):


The problem is that my 4GB Flash Voyager has stopped working at USB 2.0 speed and now only operates at USB 1.1. When it mounts I get a message saying "The device can perform faster" that its a hi-speed device connected to a non hi-speed usb hub. Even though the port is a fully operational USB 2.0 port.


I thought at first that it may have been a problem with my usb controller but I have tested it with other usb 2 devices and it works perfectly. So I checked out my Flash Voyager on a number of different computers and systems all with USB 2 and in all cases it gave the message about being a hi-speed device connected to a USB 1 port. Each of these computers had a fully working USB 2.0 port.


I tried reformatting the flash device also but it didn't make any difference.


Thanks again for your help.

Link to comment
Share on other sites

I have the same problem as you, but...


... it's only happening since I changed my motherboard. Before I had a Asus A7V8X and my Flash Voyager GT 4Go worked perfectly on my computer, but not on my friend's laptop (ASUS A6000 series) where it were recognized as a USB1.1 one.


And now i have a Asus M2N-MX SE motherboard, and my computer also recognize the USB key as a USB1.1 one! :confused:


Is there any BIOS to flash in the Flash Voyager GT? I didn't keep the box, can i still use the Warranty?


Sorry, english is not my mothertongue

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...