Jump to content
Corsair Community

MSI K9N Diamond Fails POST


Recommended Posts

Hi all, hoping someone can help!


I have an MSI K9N Diamond motherboard, an AMD Athlon 64 X2 6400+ (black edition) and two Corsair XMS2 2GB kits (part number TWIN2X2048-6400C4) giving 4GB of RAM in total.


When I try to start the system the POST fails, and the D-Bracket LEDs tell me that it's a memory problem. I've tried every combination of memory sticks in the motherboard, all with the same result. I find it hard to believe that they are ALL faulty.


I've tried booting with 1 stick in DIMM1, because I've read that I might need to go into the BIOS and set the memory voltage properly for running 2+ sticks. It won't POST with any of the sticks in DIMM1.


I've tried every combination of sticks in DIMM1 and DIMM2, and DIMM1 and DIMM3, but no luck there.


Interestingly (read 'annoyingly') the D-Bracket shows the same POST code if I try to boot with no memory inserted.


I also have my motherboard out on a table, with just the PSU, CPU, HSF, and RAM connected, so as to eliminate any unrelated rogue hardware. The PSU is the one from the Antec Sonata III case (EarthWatts 500W) and I'm pretty sure it's sound.


Any ideas..?

Link to comment
Share on other sites

  • Corsair Employees
If all of the modules will run and pass http://www.memtest.org one up but the system will not post when you have them in D/C that would suggest a problem with the MB and or CPU. I would check with the MB maker to see the BIOS you have installed will support that CPU, if it does them I would test the CPU and another system to see if the problem follows the CPU.
Link to comment
Share on other sites

Unfortunately I don't have access to another system to test the memory or CPU, so I'm stuck with what I can work out with the POST results and forums :bigeyes:


The MSI website says that the motherboard supports the processor, though I'm pretty sure there's no way to tell what version of BIOS I'm running - I don't even get any video output :[pouts:


I've also emailed MSI for help, but I'm still waiting for a reply.


FWIW I believe the POST performs basic CPU checks before checking the RAM, and everything is fine up until that point - I appreciate the memory controller is on the CPU but I would expect a failure there to result in a CPU-related error code :sigh!:


I'm mostly looking for validation that it's not the RAM that's the problem here - as I said, I have four sticks and they all fail POST, so I don't think they're to blame.


My motherboard and CPU came from separate retailers, so it looks like I'll have fun trying to figure out which one is faulty!

Link to comment
Share on other sites

  • Corsair Employees
If you were to get 4 dead modules from us I would encourage you to go buy a lottery ticket because chances are you would win a jackpot before you would get 4 dead modules from us. We test all of our modules on a MB at the rated speed before they leave the factory. So I would try and call MSI and see what they say.
Link to comment
Share on other sites

Thanks for your help on this one, I have finally solved this problem!


Before I started this thread I was doubtful 4 Corsair memory modules could ALL be faulty, but before I started pointing fingers at other hardware, I bought a cheap and cheerful little stick of K*$@!%#n RAM since it was listed on the MSI website as supported.


It gave the same problems.


A few emails to MSI later, and they were asking for the OPN on the processor because I had told them it was the 6400+ Black Edition and they didn't know what that was. So I took off the HSF, took out the processor, cleaned the thermal material off both, and noted the OPN.


Then I did a wondrous thing.


I re-installed the processor, applied some thermal material, and attached the HSF... and guess what? It only bloody worked!


I have built more PC systems than I can remember, and would never have considered the reinstallation of the processor as a troubleshooting step, because it's just so simple, and I can't see that there's any way to get it wrong. But clearly, I did something different the second time.


Oh well.


The Corsair RAM now works like a dream, as does the rest of the system. Just one note however, I needed to install a hotfix for Windows since I have 4GB of RAM installed.




This resulted in quite a few randomly-occurring STOP 0x0000007e blue screens, and a lot of head-scratching... hope it helps someone out there :)


Thanks again for help, and for the quick responses - a massive advantage in choosing Corsair!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...