Jump to content
Corsair Community

2GB boot just fine, 4GB give me a BSOD!


Shark00n

Recommended Posts

Hey guys!

 

I have 4GB of Corsair Dominator PC2-6400 C4D DDR2 RAM. As you know, these come in 1GB modules, so I have 4 modules.

 

When I assembled my system (on an ABIT IN9 32X-MAX motherboard), I only used 2GB of this memory, because a friend told me to do so or the Abit would crash during Windows Vista Installation if there were more than 3GB on it. So, I installed Windows Vista 64 bits, all the drivers and updates. All was fine, I even did a little MOH Airborne gaming with no problems what so ever!

Then I decided to put the other 2GB in. The board boots fine, gives me POST, and starts loading Windows... And suddenly!... Blue Screen Of Death, and reboots.

I've tried everything! I cranked the voltage to 2.2V, and reduced the timmings to 5-5-5-15 and 2T, also cranked the NB (680i SLI) voltage a bit, disabled "SLI READY MEMORY", and.... nothing! It always crashes while loading Windows!

 

Is there any solution to this? Is it the motherboard or the memories fault? (I've seen this motherboard handle 4GB of OCZ and G-Skill memory with no issues) And what can I do?

If there is no solution, would a 4GB (2 x 2GB) DDR2 RAM kit work flawlessly? Or am I doomed to spend the rest of my life with 2GBs?:[pouts:

 

Please help me!

 

Thank you!

 

P.S - Motherboard was flashed with it's latest BIOS version (1.3), you can also read my system specs in my profile if you need the information. Thanks.

Link to comment
Share on other sites

  • Corsair Employees

Please make sure that you have the latest bios and then load setup defaults and set the Dim Voltage to 2.0 volts and then set the timings manually to the tested settings for the specific module you have, and then test the module/modules one at a time with http://www.memtest.org! If you still get errors, please follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it! However, if you get errors with both modules that would suggest some other problem and I would test them in another system or MB to be sure. In addition, with this MB you have to disable legacy USB in the bios when running any memory test.

 

And with 4 modules you may need to set the memory frequency at DDR667 and the max Voltage would be 2.1 Volts.

Link to comment
Share on other sites

Please make sure that you have the latest bios and then load setup defaults and set the Dim Voltage to 2.0 volts and then set the timings manually to the tested settings for the specific module you have, and then test the module/modules one at a time with http://www.memtest.org! If you still get errors, please follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it! However, if you get errors with both modules that would suggest some other problem and I would test them in another system or MB to be sure. In addition, with this MB you have to disable legacy USB in the bios when running any memory test.

 

And with 4 modules you may need to set the memory frequency at DDR667 and the max Voltage would be 2.1 Volts.

 

All of them are fine.

Why would I need to setup my 200 dollar memory to a lower speed? You should say that in the package, you would have saved me a lot of money.

Link to comment
Share on other sites

Had you purchased 8500 (1066MHz) DRAM, then you would very likely had to have dropped to 6400 (800MHz). The problem is that the chipsets are not yet optimized for such DRAM density to be run at the full optimal speed of the memory. Because the que is longer, the dram needs to be slowed down to the chipsets ability to access the banks (Row and Columns). If the chipset supports 6400Mhz DRAM and you have populated the banks with 6400Mhz DRAM, then with 4GB, you will very likely have to drop to 5300Mhz Speeds.

 

Think of it this way. If you have a small phone book, then when you go into the index to find the page where you will find the phone number you are doing so at a certain speed due to the pages of the Index. Then you have to drive through the pages to get to the number. Now if your index is twice as large and the pages twice as many, then it takes longer to access the data. Now DRAM has a Strobe and the length of the strobe is how long the rows and columns can be left open before they must be refreshed. There is not enough time for the dram to be refreshed and then accessed with 4GB at the full access speed of the DRAM. The chipsets are optimized for 2GB, not 4GB. This is changing and of course there are some who can overclock the FSB to gain some extra bandwidth and thus access the capabilities of the DRAM since the chipset is now clocked up. Usually when you clock up the FSB and concurrently the Memory Controller Hub (MCH) you need to raise the voltage of the MCH a bit.

 

Hope this makes sense,

 

Derek

Link to comment
Share on other sites

Thankfully, another guy from Corsair named Yellowbeard was able to help me. I am now running my Dominator at their intended 800Mhz speed, and at 4-4-4-12 and 2T.

 

No crashes, no nothing. All I had to do was bump the FSB VTT and the NB voltage a bit.

 

FSB VTT - 1.40V

NB - 1.45V

DRAM - 2.150V

 

Working fine now. :biggrin:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...