Jump to content
Corsair Community

Flash drive "Invalid Partition" in Partition Manager 6


bracicot

Recommended Posts

Hi!

I use PortableApps to install OpenOffice and other stuff tu my students' USB drives. The kids' drives are many different brands, all 1GB in capacity.

 

Everybody has the exact same original config that I install myself. I found two funny things:

 

Whatever drive I check with Partition Manager 6.0, including my Survivor GT, shows up as "Invalid partition", however they all work fine. I deleted and re-created the partition on my Survivor: Primary, not active, FAT32, and restored everything. Still works fine, but no longer "invalid".

 

My Survivor GT will not Autorun, I tried it on half a dozen XP PCs. The kids' drives ALL autorun fine, including my Verbatim 2GB.

 

Thinking that my partitioning was the cause, I did the same thing to a Transcend 1GB drive: repartitioned and reformatted. The drive will still Autorun!

 

I have a few questions:

 

- Why do all flash drives (at least the ones I tried) all show as invalid partitions in Partition Manager? What is the original flash drive's partition ID? Maybe it's just that PM6 doesn't recognize the partition ID?

 

- Why doesn't my Survivor autorun? Driver issue? 8GB drives cannot do it? It has the exact same config as all the other drives I installed, and all of them work? XP tries to Autoplay it, but nothing happens in the end. When I right-click the drive I do have the "Launch PortableApps" option, so XP does read the autorun.inf.

 

I ran CHKDSK, and the drive looks perfectly fine.

 

Thanks for all the help you can give!

Link to comment
Share on other sites

  • Corsair Employees

Some applications like that might have strange or erratic errors with some flash drives because of the Hub/controller that is in the Flash Drive. And the same might be true for the Auto run but that should be a setting on the drive properties with in Windows.

 

And I would suggest using DOS to format the drives.

Link to comment
Share on other sites

Hi!

 

For some unknown reason, Autoplay/autorun started to work. My guess it was the computer(s), not the drive.

 

This free utility can help repair partitions on hard drives and flash drives, I found it looking for something easier to work with than booting into Win98:

 

http://www.cgsecurity.org/wiki/TestDisk

 

It runs like some fancy automated version of FDISK.

 

It comes with another program that can retrieve lost images on flash cards.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...