Jump to content
Corsair Community

Voyager GT 2GB serious problem


saat

Recommended Posts

Hello!

 

I recently bought the Corsair Voyager GT 2GB, and one day out of the blue when I inserted in my computer, the computer could not recognize it. There was a windows explorer open, that stack and then after a few minutes I just saw in the list of removable drives my corsair. But that was it. Nothing more. In properties it gives me 0 bytes and I cannot even format it. From that day, nothing has changed. Three different computers have the same reaction when I insert the voyager. They seem to freeze for a second and then 2 things can happen. Either I pull out the voyager and the system directly becomes normal again, or if I wait for a while (2-3 minutes), Windows (either Vista Business or XP) just recognize the name of my flash and nothing more.

 

Please, if anyone has any idea what is happening I would really appreciate it. The thing is that I had some really important data left in my flash (docs and pics) and I do not know how (if I really can) to recover them. I tried many software but all of them could not even recognize the drive. It was like I had never inserted it, it was not listed.

 

Thanks in advance.

Link to comment
Share on other sites

The problem is that I had some very very important files in the drive and now I am trying to recover them. I would really like to know what is the extend of the damage. I am trying to format the drive but windows won't even open the format window (when voyager gt is inserted in the system). Is it really bad? Can you think of any software that could recover any part of my data? I am desperate, any help would be appreciated.

 

Thanks again.

Link to comment
Share on other sites

  • Corsair Employees

Yes, if you need to recover some data there are some third party utilities available that may help you if you have some data you need to recover from this site that may work as long as the drive is detected and assigns a Driver letter.

If you still have problems, let’s get it replaced. Please use the RMA request found in TSXpress or follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...