Jump to content
Corsair Community

Problem with 4GB Flash Voyager - USB2


pxm

Recommended Posts

The device after working fine for months now everytime i insert it into a PC that has USB2 reports that the device will work faster in a USB2 port.

 

The PC ports are definitely USB2 and this happens on multiple machines, XP & Vista.

 

If i wipe and reformat the device will this resolve the problem ?

 

Please help, i miss my device speed.

Link to comment
Share on other sites

  • 3 weeks later...
if you're running windows than it can very well be that your USB2 driver is messed up - the system works with USB2 ports using USB1 drivers. Are other USB 2 devices plugged in the same port working on full USB2 speed? Alternatevely, have you tried plugging your stick into other PC's with USB2, prefferably running MacOS or Linux?
Link to comment
Share on other sites

alexandrucirip - As previously said - this happens on clean brand new pc's as well - so not a driver issue

 

I have the same, both under windows and under linux. It is definately a hardware issue. Other usb sticks work fine in the same port at USB2 speed, but the corsair voyager is recognized as USB1 only.

Link to comment
Share on other sites

  • Corsair Employees
Let's get them or it replaced. Please follow the link in my signature “I think I have a bad part! Or *New* Tech Support Express” and we will be happy to replace them or it, please note that you are posting from the forum!
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...