Jump to content
Corsair Community

BF2 Patching and Memtest errors


Alexmagic

Recommended Posts

Hi All,

 

I've been having issues patching BF2 and have been pointed here to try and sort it out. I kept getting patching failed erors when i tried to patch this program, always on the same 500MB+ file. EA recommended i test my ram using memtest and it kept giving me errors (let it cycle through all tests 10 times over 8 hours) on Test number 7, on both my sticks (ie. errors <1000MB and >1000MB). I just got this system of a mate... A little details about my setup for clarification before i really go into it:

 

Mob: Asus P5W DH

CPU: Intel E6300 OC'd to 2.63GHZ

GFX: EVGA 7900GT 256MB

RAM: Corsair Dominator 6400C4 DDR2

PSU: Seasonic S12 Energy Plus 650W

 

The rest is unimportant (i think)...

 

Do errors in memtest automatically mean my ram is faulty? or should i look into the bios settings before i send it back to you guys for replacement?

 

If you need any more info just let me know - Thanks for your help!!

Link to comment
Share on other sites

While i'm thinking about the setup i've read a lot on the forums about recommended voltages and legacy being switched off etc...

 

I'll test the system with legacy turned off etc but will that have any effect on my RAM as it is meant to work in Windows, or will it only affect how it works when its running through Memtest?

 

Very keen to get this sorted but it seems i might be destined for problems as there are a lot of people on here with this mobo/RAM combo...

Link to comment
Share on other sites

OK, back at home finally and it's set up as follows in Bios:

 

AI Overclocking - Manual

CPU Freq: 375

DRAM: DDR2 750 MHZ

Performance Mode: Auto

PCI-E Freq: 100

PCI Clock Synch Mode: 33.33MHZ

Mem Voltage: 2.1

CPU VCore Voltage: 1.2875

 

RAM: PC2-5700

Timing: 4.4.4.12

Write Recovery: 4

Hyper Path 3: Disabled

DRAM Throttling Threshold: Auto

Memory Remap: Disabled

PEG Buffer Length: Auto

Link Latency: Auto

PEG Root Control: Auto

 

If there's anything i missed let me know. I've most likely given you too much info but i'd rather not miss anything out if its important :)

 

I tried running memtest86+ with the legacy turned off, and still getting a bunch of errors in test #7 (about 8 per pass).

 

Specifically the RAM is TWIN2X2048-6400C4D

 

Any suggestions for what i should try next?

 

What does it mean when only test number 7 is causing me issues?

Link to comment
Share on other sites

I De-clocked everything and set the ram to 800mhz, 4.4.4.12-4, and 2.1V and no more errors...

 

I'll install and patch bf2 now and see how it goes - hopefully it will work fine then i can try and get it overclocked again.

 

Will it run ok if i leave the ram at these settings and crank the CPU about by itself or should i try to stick to the 1:1 ratio (I don't know what this means but i've been told to do so by the dude that set it up for me)?

 

EDIT: I was thinking about setting the CPU FSB frequency to 400 so it runs at 2.8GHZ (Same mobo/ram/cpu config does 2.93 in an article i've found with tno probs at all with my cooler) which would mean the ram and cpu would be running at the right ratio...

 

Will it hurt my system to give it a go? will i get a warning if it is about to eat itself from the inside?

Link to comment
Share on other sites

  • 1 month later...

Hi RAM guy - things have been better but are getting slow again...

 

Started getting similar symptoms again... used memtest, i get no errors on either stick individually, but with both sticks in either channel i get errors in test number 7 again. Orthos seems to pick it up a little quicker...

 

Tried relaxing the timings to 5 5 5 16 5 but still no go...

 

Happy to accept if you think its not that the ram is buggered - just looking for ideas as to what i should do...

 

My FSB: 400, Ram Freq: DDR 800MHz, Mem V:2.1, CPUV:1.2875, MCHV:1.65...

 

Asus P5W DH, Intel E6300 (@2.8GHz), 2GB Dominator 6400 C4D...

 

Thanks for your help :)

Link to comment
Share on other sites

  • Corsair Employees
I would recommend that you underclock the memory to 667MHz to see if it is the CPU that is giving the errors, and then set it back to 800MHz and underclock the CPU. This will at least let you know which part is not working well with your settings.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...