Jump to content
Corsair Community

Memory errors with 4 sticks installed


Mikee99

Recommended Posts

Hello,

 

I am currently running Windows Vista Home Premium 32-bit. Here are my specs:

 

Motherboard: Gigabyte GA-M55SLI-S4 (rev 1.0)

Processor: Athlon 64 X2 4200+

RAM:

CORSAIR XMS2 1GB (2 x 512MB) 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400) Dual Channel Kit Desktop Memory (newegg link)

and

CORSAIR XMS2 2GB (2 x 1GB) 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400) Dual Channel Kit Desktop Memory (newegg link)

 

So, I have 3 GB total.

 

Here is my issue:

 

Today I was browsing the web and using Photoshop, and it gave me a blue screen. The error was "Memory_Management". Obviously, I was very concerned. I have had 3 GB installed since June (prior to this I only had the 2x512), and have been without issues.

 

I decided to run the Windows Memory Diagnostics Tool. It restarted the system, and performed the test. The result of the test was that there was a hardware error.

 

So, I removed the 2x1GB sticks, and just kept the 2x512 sticks in. I ran the test, the test passed.

 

Then, I removed the 2x512MB sticks, and just kept the 2x1GB sticks in (different slots than the 512's), ran the test, and the test passed.

 

When I have all 4 sticks installed, the test reports an error.

 

I then decide to load Memtest from my Ubuntu cd. It kept finding lots of errors (w/ 4 sticks installed).

 

I then checked those 2 ram sticks on newegg, and I found this:

The timing of the 2x512 sticks are: 5-5-5-15

and the timing of the 2x1GB sticks are: 5-5-5-12

 

I checked my BIOS, and I couldn't find a setting to set the timings. Could the difference in timings be causing the issue? I've only had that BSOD once, and I play lots of FEAR, which is very intense on system resources.

 

Any and all help would be greatly appreciated!

Link to comment
Share on other sites

  • Corsair Employees
With more than 2 modules installed I would suggest setting the memory Voltage to +.2 Volts and set the memory frequency at DDR667 and just let the MB BIOS set the timings or set them to Cas 5-5-5-15 at 2T CPC/CR.
Link to comment
Share on other sites

Hello,

 

Thank you for the fast reply.

 

Unfortunately, since I upgraded my MB's BIOS, they removed a TON of features. I don't know WHY they did that for. There used to be an option titled "DRAM", and in there, there were options on how to configure just about everything with your RAM. It is no longer listed there. The only thing I can change is the memory voltage to the .2.

 

I have attached two screenshots of CPU-Z with some memory information. In screenshot 1, it's showing the Memory tab. In screenshot 2, it's showing the specific stick in slot 1. The information regarding the latency is the same for the rest of the slots. So, does that mean they are all operating at the correct latency? I really don't know how to read the information, but it appears to be the same throughout.

 

I did not change the voltage yet. What effect does changing the voltage do? I want to be careful with the voltage since I don't want to burn something out.

 

Thank you for your assistance.

 

[EDIT] I just noticed my CPU bus speed is at 201Mhz and it should be at 200. I tried the "Load Optimized Defaults", and I guess that changed it.

 

[EDIT] When I changed the CPU setting from "Auto" to 200, when I restarted, in the first BIOS screen, a message flashed where it normally tells you the CPU frequency, and it said: "Over clock CPU frequency now!" So, I set it back to Auto. But it's strange, since it always used to run at 200. I would rather it run cooler and with the lower clock speed. I'm going to try it at the lower clock speed.

 

[EDIT]When I changed it to 200, CPUz reports that it's running at 193! This is weird!

Memory.jpg.e542c8730c07d6b44b6c0bfd71c2d015.jpg

Memory2.jpg.bd77030b490044f8803cb957206bb83d.jpg

Link to comment
Share on other sites

i've just updated the bios... no change.

 

when i first assembled the pc, i had issues with putting the two RAM modules in slots 1 and 2. every 2nd or 3rd boot, the screen would have strange vertical stripes, and would hang before booting up into windows, then give a blue screen, something about page faults. so i shifted the RAMs to slots 3 and 4 and didnt get that problem again (but now realise theyre operating as single channels).

 

ive since moved them back to slots 1 and 2, and the problem is still there, with blue screen errors (and still showing as single channel).

 

i did a memory diagnostic tool test (the one that comes with vista, as an option before windows starts), and it said there was a fault in the hardware and to contact my vendor. but the RAM runs fine in slots 3 and 4 (just not as dual channel).

 

pretty strange situation. i dont overclock or anything, settings as they were from manufacturer.

cpuz1.jpg.6e64d9202e63a7499c941e0da795b039.jpg

cpuz2.jpg.fd8cb559272080cc91af08acef6153f2.jpg

cpuz3.jpg.6a8cad3e72faecef67a3fb64979a36da.jpg

Link to comment
Share on other sites

Hello,

 

I'm not exactly sure where to get the memory clock speed, since they removed that setting from the motherboard. However, I ran memtest, and it said: DDR402 on it. I do not know what that means.

 

I ran the memtest with both, the upper voltage and lower voltage. This is what I got from it:

 

Tests 0 and 5 were fine. Tests 1, 2, 3, 4, 6, 7, 8, 9, 10 all had errors.

 

I have noticed in the error report, the following megabyte numbers were always given: 764.2MB(most frequently reported), 764.3MB and 765.3MB. Does that mean I have a defective module at a particular point?

 

Should I try running memtest again with the isolated modules (2x512 then 2x1GB)?

Link to comment
Share on other sites

  • Corsair Employees
No I would suggest testing the modules on a known working system and you should not be running test 9 or 10 on memtest on a X-86 system, just use the default tests and set the tested settings and if you do not know for sure what you are setting in the BIOS I would not suggest playing with it.
Link to comment
Share on other sites

Ok, I conducted another experiment.

 

I installed an older version (F4) of my MB's BIOS, and I ran memtest with all 4 sticks installed. 0 errors were reported.

 

In BIOS revision F5, they altered the settings of the M.I.T. group. My guess is that is when they altered something and broke some functionality.

 

Unfortunately, Cool&Quiet under Vista will not work with the older revision, F4. It does work with revision F10. So, which would I rather have? A cooler, quieter system, or one that is more stable. :sigh!:

 

So really, Gigabyte can fix the issue. When I get another response from their tech support, I'll inform them of this.

Link to comment
Share on other sites

Sorry for the triple post.

 

I installed ntune, and in it, it provides a ton of options. I attached a screenshot of what it looks like with the current settings.

 

How does ntune work? Does it modify the BIOS settings, or does it change the settings on the fly when it's loaded in Windows?

 

EDIT: Unfortunately, there is no "Dynamic BIOS Access" page in ntune, b/c my MB doesn't support it. This is such bull****. I will never purchase another Gigabyte MB!

ntune.thumb.jpg.d92abeb4173cbfcf77a9f519f0bc6b63.jpg

Link to comment
Share on other sites

  • Corsair Employees
NTune changes the settings by changing the registry setting in Windows it does not change the BIOS settings, I would suggest contacting the MB maker and asking them how to set the memory frequency at DDR667.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...