Jump to content
Corsair Community

HX-520 Power on problem


gak79

Recommended Posts

Hi,

I've just upgraded my rig from X850XT 256 PCIe to Sapphire X1950XT 256 PCIe and PSU from Tagan 430W to Corsair HX-520. My problem is to power on my rig. When I connect power cord to PSU and switch it on, everything seems to bine, led's are lighting, but when I tried to power on my system, the leds just blink, then turn down and after while they're lighting again. If I try to push the power button on case min. twice of more times, then the system posts and boots normally to windows.

 

If I will restart comp from windows, it restarsts normally and no probs to load windows. But if I turn off computer from windows or by power switch on case, then there is the same problem with powering up my comp. I must switch PSU off, pull off power card from psu and then reconnect the power cord again and switch psu on. Then happens the same problem with powering on (must push power button on case min. twice or more times and then it normally boots to windows and can work with comp without probs).

 

If the system is on, had no problem runnig anything. I have overclocked CPU and tried to set it to default, but there was still that problem after that.

 

My rig:

DFI Lanparty Ultra - D nF4 ultra

Sapphire X1950XT 256 PCIe+Zalman VF 900 Cu

Opteron 144 1800@2700

A-DATA Vitesta Extreme DDR500@550

Hitachi 160GB 7200RPM PATA

NEC DVD - RW 3520

Corsair HX-520

Thermaltake Soprano

2 x 120 mm fan

1 x 90 mm fan

 

I would be very happy If we could resolve this problem and could use this PSU without any problems.

 

THX for replies.

 

BTW sorry for my english, I am Slovakian.

Link to comment
Share on other sites

  • Corsair Employees
Did you load setup defaults when you made the hardware change? If not please try and reset the BIOS and then load setup defaults and set what ever other settings need to be set and see if that will solve the problem.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...