Jump to content
Corsair Community

Corsair 2GB Dominator PC2-6400C4 (2x1GB)


grey101

Recommended Posts

I have just finished building a new PC and was very excited when i came to turn it on. I hit the power switch, fans buzzed to life (heat sink & case fan), but alas nothing appeared on my monitor. I have checked over all my connections etc, and everything is in order and all the components are compatable as far as i know. I think the problem may be due to the RAM Corsair dominator PC2-6400C4 TwinX (2x1GB). I think this because i had a similar problem when using incompatible RAM before by accident, and also because i have read that this specific RAM requires a higher voltage and on some systems will not boot? (http://www.overclockers.co.uk/showproduct.php?prodid=MY-124-CS&tool=3)

I was hoping someone might know something about this, and whether it might be a likely cause of the problem, have already tried a different Graphics card, i guess the mobo or cpu could be wrong but i find it hard to believe any of the components fresh outta the box are defunct. Thanks for any help you can give. grey

Link to comment
Share on other sites

  • Corsair Employees

Can you tell me the make and model of MB you have along with the CPU speed and it’s FSB as well? In addition, please tell me the bios settings you have set for both CPU and memory and any performance settings that you may have set?

 

I would try just one modules and then clear the BIOS with the Clear C-MOS jumper on the MB and see if it will post

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...