Jump to content
Corsair Community

Flash Voyager GT Broken?


calext

Recommended Posts

I recently purchased two 4Gb flash Voyager GT's to replace my 2Gb ones and well I've been using one of them for about a week now but when I tried my second one it doesnt work, no light or anything, windows says it can't detect the item, or that the USB device is unrecognizable. I've tried it in serveral other computers, and it does not work. The other one works fine and has no issues.

 

The numbers on my device are 304G FMB750377 07196020-0 I would send it back to NewEgg but I've already thrown away the packaging. I figured corsair was the best and I've never really had issues with them before...

 

Anyways please help, what do I need to do to get an RMA?

 

-Brandon

Link to comment
Share on other sites

  • Corsair Employees
Let's get them or it replaced. Please follow the link in my signature “I think I have a bad part! Or *New* Tech Support Express” and we will be happy to replace them or it, please note that you are posting from the forum!
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...