Jump to content
Corsair Community

striker extreme & 8500C5D ?


extremebob

Recommended Posts

I've been planning to get 4 gigs of Corsair TWIN2X2048-8500C5D Dominator but when I check my mainboard (asus striker extreme) it says that it only supports up to 800mhz memory. Does this mean that it will run the 8500C5D at 800 mhz or just don't work at all?

 

If it runs it at 800 mhz can I clock it back up to 1066 later on and get the same stability and performance or should I just get the 6400C4D? Will the 6400C4D perform better in my case?

Link to comment
Share on other sites

  • Corsair Employees
This MB will over clock to 1066 With two modules installed with no problem as long as you have a 1066 FSB CPU. With 4 modules DDR800 would be suggested but you can over clock the CPU to get the memory speed at the tested frequency.
Link to comment
Share on other sites

This MB will over clock to 1066 With two modules installed with no problem as long as you have a 1066 FSB CPU. With 4 modules DDR800 would be suggested but you can over clock the CPU to get the memory speed at the tested frequency.

 

Hello RamGuy,

 

I have an Asus P5N32-E SLI board and I bought 4 GBs of 8500C5D ram. The BIOS version of the board is 1102. But with 4Gbs the system is unstable and IT CANNOT use 1066 Ram frewuency no matter what...I followed the Corsair forums and applied several solutions but alas...What is wrong ???

Link to comment
Share on other sites

  • Corsair Employees

You would need to set the memory frequency at 800 or 667 Mhz with 4 modules and make sure that you set the command Rate to 2t as well. And SLI Ready memory should be disabled:

SLi ready: Disabled

Memory Voltage: 2.0v

NB Core Voltage: 1.4v

TCL: 5

TRCD: 5

TRP: 5

TRAS: 15

Command Per Clock: 2

TRC: 24

Link to comment
Share on other sites

Well as you can imagine this has been quite a journey up until this point. Firstly, my board was DOA and then I needed to get a stick of VS memory just to get into the boot screen.

 

I was able to install Vista 64Bit, but only after removing 2 sticks of ram. So I guess, I need the latest and greatest recommended settings for this board and ram combo because this instability with 4gb is killing me.

 

I currently have the memory set to 2.0V 800 5-5-5-15 with all spread spectrum off and voltages set to auto.

 

It sounds to me like the ram controller needs some extra juice so please let me know what settings I should use to get a stable system going.

Link to comment
Share on other sites

You need to set the settings I gave previously and what O.S. are you using? If its Vista there is a patch you will need to install for more than three gig of memory.

 

I am using vista 64bit. The instability however is at the bios and boot level. 100% rock solid with 2gb.....about as stable as a 3rd world government with 4.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...