Jump to content
Corsair Community

Lacking correct screws


808jrh

Recommended Posts

Aloha All!

I am having a heck of a time with this situation. I purchased a Nautilus GPU waterblock and when i went to put it on my vid card i found that i was short 3 of the 0.25" Hex screws and had 3 extra 0.5" screws.:(: I contacted Corsair customer service to ask for some help and i was told to request an RMA and to send everything back to them for a replacement! :confused: So i complied even if this seemed like a lot of trouble for 3 tiny screws. I sent the RMA back to Corsair on the 11th of May. Today (4th of June) i received my replacement from Corsair and guess what i found. That's right the same problem with the screws!!!:eek: This is from what i assume is a factory sealed box. So is it just my bad luck or is there a problem with quality control at Corsair? Anybody else have this happen??? I guess i'm going to have to call them again tomorrow as it's already to late today. 808jrh

Link to comment
Share on other sites

Ram Guy,Got your message after i got home from work. i've resent the email. it's kinda hard to coordinate when there's a 3 - 4 hr. time difference isn't it? Oh well i guess we'll just have to work our way through this mess the best we can!!

 

 

 

808jrh

Link to comment
Share on other sites

Just got up and checked my mail....still nothing from anybody about this problem. Hope this doesn't take all day as it's friday again and i know there will be no help during the weekend!

 

808jrh

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...