Jump to content
Corsair Community

4gb Voyager GT RMA request


highoctane

Recommended Posts

Hello, I just received a replacement 4gb Voyager GT today after RMA'ing my first one that just quit working.

 

Well the replacement I received seems to have a problem right out of the packaging. I thought it was complete DOA since I got no blue light and none of the computers I tried it in could properly identify the hardware and no blue light flashing at all.

 

So I decide to just kinda push with a decent amount of force on the top of the thumb drive and the blue light starts flashing along with the hardware being recognized, I've tried it directly plugged into the usb port and with the included cable and get the same thing, you have to push and hold the flash drive bent over to work.

 

Needless to say this replacement drive is totally unusable and is literally fresh out of the package this morning. It seems either internally there is a loose contact or there is an issue with the terminals in the thumb drive itself.

 

Its a shame I've had no problems with the two 8gb voyagers I have but this is the 2nd problem in a row in a very short period of time with a 4gb voyager gt.

 

I can understand one problem but I don't feel I should be paying the shipping back on this item as it has arrived to me pretty much DOA or unusable, I already paid for shipping to RMA the first drive.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...