Jump to content
Corsair Community

Bad 2gb XMS2-6400 RAM


Recommended Posts

I have a pair of Corsair CM2X1024-6400 (XMS6405v5.1) sticks of RAM that are failing Microsoft's memory diagnostic. I've checked to ensure that the voltage was set to 1.9v, manually set timings to 5,5,5,12, put them in a different computer (Asus P5N32-E SLI motherboard) and it fails exactly the same. I bought a new set of the same RAM and it works at the exact same settings and timings. I need this set replaced though. What can I do to get an RMA? I've checked with NewEgg where the RAM was purchased last year but apparently it has to be handled by the manufacturer. Help please!
Link to comment
Share on other sites

Thanks. I submitted the RMA form online and we'll go from there. This is the first of many many Corsair modules I've used to go bad. Hopefully it'll be the last. I've used Corsair's memory products for the last 5 years with great success and hope to continue doing so...
Link to comment
Share on other sites

Maybe it's too early to ask this but I just submitted the RMA form and it just redirected me to the home page with no notification as to whether or not it was successful in submitting the request or anything. I also haven't received an email with an RMA number yet. Should I be waiting for the email or do I need to go back and re-submit that form?
Link to comment
Share on other sites

  • 4 weeks later...
  • Corsair Employees
I am sorry we can no longer check RMA status in Tech Support; please call our customer service at 888-222-4346 or 510-657-8747 Ext “0” or send them an email (rma@corsairmemory.com) with your RMA# and ask them for the status!
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...