Jump to content
Corsair Community

Asus P5WD2-E Premium issues with PC8500C5D Dominator


Bubbidolo

Recommended Posts

Hello. Got some big problem making my system work with brand new PC8500 Dominator 1066Mhz. One of the two 1Gb module goes completely unseen by my computer: it simply does not even load startup screen.

With the other module, which is seen as a standard PC5300 DDR2, I am able to access BIOS.

Via BIOS I adjusted setting to match manufacturer specs, but WinXp does not load and the system hangs with subsequent reset or blue screen reporting memory error message.

I have even tried to adjust voltage manually, up to 2.20 Volt: the system seemed to load correctly, but as soon as desktop screen appeared a high pitch shrieking sound literally exlploded from my speakers and I was forced to turn off the computer.

I tried to use every single DDR2 slot, but obtained no result.

I wonder if there is a terminal compatibility issue between PC8500 Dominator and my MOBO, Asus P5WD2-E Premium, although the BIOS tells me I can set Mem frequency up to 1067 Mhz(manually) and set CAS timing as indicated by Corsair (5-5-5-15-2T).

I have obviously upgraded BIOS and drivers for every single periphereals, except, perhaps, the Sound Card.

Please, if anyone knows something about this issue, tell me.

Thank You.

Link to comment
Share on other sites

  • Corsair Employees
First thing with the MB and CPU you have listed and 4 modules you will need to manually set the memory Frequency at DDR-533/266 MHz. And even if you had a 1066 FSB CPU you would need to set the memory frequency at 667 with 4 modules on this MB.
Link to comment
Share on other sites

Asus customer service sent me an e-mail: they say that PC8500CD Dominator are NOT certified for my motherboard P5WD2-E Premium.

But on the official site of Corsair Dominators are indicated as suitable.

What does it mean?

Thank You

Link to comment
Share on other sites

  • Corsair Employees

:bigeyes:

This MB is rated at DDR800 Max and would have to over clocked to run 2 modules at 800 MHz. These modules are beyond the rated spec of this MB and as such most MB makers will not test with over clocked parts. And they would not show up on their QVL list, that is normal. And I am sorry but if you don't know what you are doing with over clocking I would suggest that you just get One VS2GBKit667D2 and just load setup defaults and then you don't have to change any settings.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...