Jump to content
Corsair Community

520hx turns on and off


Tolga2323

Recommended Posts

So the PS worked for a day or two normally and then bang, it gives out (no over clocking or fiddling with the settings). The funny thing is that it turns on for 3 seconds, and then turns off, turns back on for 3 seconds and turns off again. I hear some sort of buzzing noise when the fan rotates too.

 

I am currently using a Gigabyte DS3 mobo with an e6600. Is there a fix or should i RMA this thing?

 

Thanks

Link to comment
Share on other sites

Is it possible you have a MOBO short to the case or around the I/O panel? you may want to test it with the MOBO outside the case to be sure. However, if the PSU is defective, we'll gladly replace it or, you can contact your reseller if you prefer.
Link to comment
Share on other sites

  • 4 weeks later...

mine is doing the exact same thing. I have the same mobo as you also except Im running the e4620. Im going to try it out of my case like they suggested, please let me know if you figure out the problem.

Thanks

Link to comment
Share on other sites

Also, I have to mention mine never worked so at least you got something out of yours. Well I took it out of the case and it did the same thing it was doing... 3 seconds on then turns off. Does this over and over again. I am not sure what to do because now I have limited it to my mobo, or my psu?
Link to comment
Share on other sites

no I dont have another PSU. However, I was going to run by compUSA and get a PSU tester just to see. I think it is probably a circuit problem in my mobo thought. Anyway, its not very common for one of these things to come DOA is it?
Link to comment
Share on other sites

  • Corsair Employees
Please call our Tech support at 800-205-7657 and we will try to help you solve the problem, and our hours are from 8:30 AM to 5:30 PM Pacific Time Monday threw Friday excluding holidays!
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...