Jump to content
Corsair Community

HX620W for breakfast.


mcheer

Recommended Posts

Hi,

 

I built a new PC with an HX620W and it worked for 1-2 hours - enough time to install XP. I then switched off the PC (but not from the PSU). After about 15-20 minutes, the PSU literally fried itself - buzzing, screaming, smoke, etc.

 

I have no intention of testing it again and will RMA it, ASAP. I can only hope that the brand new Mobo, CPU and 8800GTX are still okay?!

 

Anyway, I've never experienced this from a PSU before and are quite pedantic with my PC builds. Before I install the replacement, I wish to confirm whether there was anything I could do to prevent this... or whether I just got unlucky?

 

I appreciate any feedback. Many thanks.

Matt.

Link to comment
Share on other sites

  • Corsair Employees

Let's get it replaced, please use the On Line RMA Request Form and we will be happy to replace them or it.

Or if you can please call our Tech support at 800-205-7657 and we will try to help you solve the problem, and our hours are from 8:30 AM to 5:30 PM Pacific Time Monday threw Friday excluding holidays and ask for Ram Guy!

Link to comment
Share on other sites

  • 2 weeks later...

Hi again,

 

Thank for your response. I got the PSU RMA'd through the retailer and have already installed the replacement. Fortunately, the fried PSU didn't take anything with it.

 

The new PSU runs perfectly and much cooler than the faulty one did for the 1-2 hours of it's life - which is further indication of some fault. Otherwise, I'm pleased with the outcome and very happy with the PSU.

 

Cheers,

Matt.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...