Jump to content
Corsair Community

Another RMA gone MIA?


cmp

Recommended Posts

RMA r244727

Case #116084

 

It has been almost 4 weeks now, and I am not getting any response from ANY emails that I send. When I called in, I was told that you had upgraded to/from Oracle to/from another system and that my info was "in limbo". That was over a week ago the item was shipped the last week of March...far from a 2-3 day turn around. Still not getting a response after 3 days of emails.

:mad:

Link to comment
Share on other sites

I have a similar problem. No contact, no response to email. Searched forum for RMA and found a number of customers not entirely happy, but a ray of hope, in answer to one post Ram Guy suggested sending an email to: - rma@corsairmemory.com Strange that this email address is not immediately apparent on the website.

 

Good Luck Wads

Link to comment
Share on other sites

Also, another note on this...

 

I can no longer log into TSXpress to look at the RMA info as it tells me that the password is invalid, even though it is the same password that is sent to me when I hit "Request Password".

 

:(:

Link to comment
Share on other sites

Ram Guy - I just received an email stating that my SD card was received and a replacement was to be shipped out tomorrow. I will follow up in a couple days once the tracking goes through or the item arrives.

 

Thanks

Link to comment
Share on other sites

Just posting back as promised to let you know that the replacement part did come in today as promised and was shipped/delivered on time.

 

Thanks for your help in this matter.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...