Jump to content
Corsair Community

4GB Flash Voyager works only with USB1.1


Surikan

Recommended Posts

I have a flash voyager 4Gb (bought 4 month ago, was a christmas gift).

Since yesterday each time I connect it to the computer (with USB2.0)

I get a error message "Unrecognized USB Device". I tried to do with USB1.1

and it works, but not with USB2.0.

I tried this on more then 5 PCs - every time the same result.

I installed my WinXP and SP2 with updates again (fresh installation) and

I also tried to format Flash Voyager - with no success! :bigeyes: :confused:

Please help! What is happened? :[pouts:

I would like to RMA it. Is RMA in Germany possible?

Thanks.

 

My OS: WinXP Pro SP2

Link to comment
Share on other sites

  • 5 weeks later...
  • Corsair Employees
It will take about 24-48 hours excluding weekends and holidays if not please either call our customer service at 888-222-4346 or 510-657-8747 and dial "0" 8:00 AM to 5:00 PM Pacific time Monday Threw Friday excluding Holidays or follow the link in my signature "If you have submitted the RMA using the on line form and have not got a reply!"
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...