Jump to content
Corsair Community

HX620W No Hard Drive


swettylez

Recommended Posts

This has got me stumped so any help would be much appreciated.

I've just took delivery of a HX620 Power Supply to go into a new rig I'm putting together over the next month when funds allow.

Anyway I thought I'd try it out in my present system just to see if it's as good as all the reports I've been reading and I've ran into a strange problem.

The system powers up fine but hangs for a while then I get the message cannot detect a hard Drive.

If I connect the same hard drive to the Secondary IDE Controller it picks it up instantly.

Now let me explain that I've tested everything fully and by a process of elimination and I know that everything is working correctly, the Hard Drive, IDE Cables, and both IDE Controllers.

I know this to be the case because if I connect the original Antec 400 Power supply to the motherboard then everything is detected as it should.

BUT with the HX620 powering the board as soon as I connect any device (either Hard Drive or Optical Drive) to the Primary IDE Controller it is not detected.

I've tried every IDE connector that came with the Supply in every Rail and still no joy.

Are there any known issues with this board or can anyone offer an answer.

 

ASUS A8V-Deluxe

AMD64 4000 San Diego

Nvidia 6800GT

2GB ******** PC3200

500GB IDE Seagate Barracuda

Pioneer 112D DVD

 

Thanks

Link to comment
Share on other sites

Just to add. I've connected this supply to my other computer which uses exactly the same motherboard but with a slightly earlier Bios version and the results are exactly the same. Anything attached to the Primary IDE Controller cannot be detected.

 

Anyone???

Link to comment
Share on other sites

Thanks for the reply Ram Guy.

 

As to your questions

 

1 The Hard Drive works fine with 3 other power supplies.

 

2 Only other Motherboard I have access to is another A8V-Deluxe and I get the same problem. I have now tried 3 different IDE Drives with this supply and the same error occurs.

 

I now know what the problem is, it's the Molex Power connectors that come with the Power Supply.

The supply is shipped with 4 IDE Type leads as follow:

 

1 Lead - 2 Molex

1 Lead - 2 Molex

1 Lead - 3 Molex

1 Lead - 3 Molex

 

Now I had a good mess about with it yesterday and found that out of the 10 possible Molex Connectors only one would allow the IDE Drive to be recognised so the correct power contact is obviously not being made. Conversely these other 9 connectors are quite happy connecting to Optical Drives or the Graphics Card.

 

I thought the Power Connector on the drive itself must be a bit loose BUT I've connected 3 different Power Supples with a dozen or more Molex Connectors to it and each and everyone of them allows the drive to be detected. So it's got to be that there's a tiny bit play on the supplied connectors which is just enough to prevent correct power detection.

Link to comment
Share on other sites

  • 2 weeks later...

Hey Ram Guy

 

thanks for the reply and offer to RMA. I'm in the UK and to be honest I don't really fancy sending it off to the States and then finding the new one has the same cable problem.

The power supply itself is absolutely spot on and with a bit of careful DIY I've managed to cobble together a couple of working IDE leads using the supplied ones and some spare molex connectors and they work fine.

Thanks again for the offer.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...