Jump to content
Corsair Community

4GB FlashVoyager not detected.


Recommended Posts

Hello, I have a Flash Voyager 4GB PID-612CAS0. This drive was transfering data to my computer and stopped working. It acted like it was removed from the system. It is not being detected in the device manager. Have tried this drive in 3 different computers. Also with leaving the drive in while the system is booting, it is still not being seen. When plugged into a system does light does not flash and is never recognized by windows. If an RMA is created is it possible to drop off the faulty drive at the Cosair offices? Working in fremont this is down the street from where I spend my days. Thank you in advance for all the possible support and replys.


-Sean E.

Link to comment
Share on other sites

  • 2 weeks later...

hey ram guy

i have also recently bought a 4GB flash voyager flash drive. Very excited i plugged it into my 5 year old Dell laptop running XP SP2. running fine for about 10 mins, i started copying my files to it. luckily they all finished copying, but minutes later i got an error message saying Drive not recognized.

So i re-formated it and still got the same problem.

this continues to happen on other computers, a apple Imac, and IBM think center's.

I'm pretty sure its a problem with the connection, as i also tried on the provided lanyard USB cable, and i bumped it ever so slightly, it still looked to be connected, but i got the message again.

It still continues to be temperemental, and disconnects randomly.


Any suggestions?


P.S after reading that i wasn't the only one with this problem, i was slightly relieved, now thinking a design error.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...