Jump to content
Corsair Community

Cannot format Flash 1gb Voyager Pen


PAULT

Recommended Posts

Hi

My Corsair 1gb Flash Voyager Flash Pen was working fine until I took it out of an windows XP machine and placed it into a vista machine to transfer information. It has since corrupted and tells me to format the pen. I have tried to do this but it tells me the pen is locked. There is no switch on the pen and I have also tried to format through Disk management but with out success. Is the pen recoverable or should I go down the RMA route? How do I format it? Is this something that will go wrong in the future. (ie a compatability issue between XP and Vista or was I just unlucky?) Thank you

Link to comment
Share on other sites

  • Corsair Employees

With WinXP Only!

Please try and format your Flash Voyager with Corsair EZ-Recover Utility. Please note; this will not recover Data; it’s made to recover the FAT table for the Flash drive.

But First if you need to recover some data there are some third party utilities available that may help you if you have some data you need to recover from this site.

If you still have problems, lets get it replaced. Please use the RMA request found in TSXpress or follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...