Jump to content
Corsair Community

P5B Dlx & 6400C4 - weird issues


Pajda

Recommended Posts

Hi

 

At first my spec:

P5B Dlx - 1004 bios

CD2 E6400

2x1024GB 6400C4 - XMS6404v2.1

chips -> 0636063-3

 

I have some weird issues with my ram, when i set everything at stock, loaded bios defs, all OC settings auto, the mem will pass 12h+ memtest but it will fail orthos blend test (max 1h), some random reboots. When i set all OC settings manually (def speeds, stock voltages, etc and mem to 2.1v 4-4-4-12) the same happend as above mentioned, but when i set mem to 1.9v it all goes well, rock solid, 15h+ orthos blend stable. Imagine that i can even go at 980MHz mem speed with 1.9v 5-5-5-12.

 

So my conclusion is that if i set mem voltage anything above 1.9v it will fail at orthos and the system became unstable.

 

I can even boot at 5-5-5-12 1000MHz mem speed but at 2.1v - no errors in memtest, orthos fail.

 

Does anyone experianced such issue? Im really curious whats up with it.

Is this mem fault or mobo?:sigh!:

Link to comment
Share on other sites

I picked up virtually the same setup as you a few weeks ago. P5B Deluxe, 2Gb of 6400C4, E6400. I too had problems running blend tests at virtually any setting, including relaxing from 4-4-4-12 to settings like 5-5-5-15 or the SPD default 5-5-5-18. I could get memtests to run for 16 hours at these or tighter settings, but whenever I tried any Prime95 runs that tested the RAM it would fail after anywhere from minutes to several hours. The one consistency was I almost always had the RAM at the quoted 2.1v. I never even thought to try to relax the volts... Though now that I think about it the only times I recall it seeming to be stable was when I was running under 2.1v.

 

Maybe I'll look into this more again trying 1.9v or 2.0v or so and seeing what I can get. I also want to try the new 1004 BIOS as well.

Link to comment
Share on other sites

I had problems running blend tests at several RAM voltages last night. These, along with my blend test problems in the past, lead me to believe that it's more the CPU to memory interface through the northbridge that is the problem.

 

Are you running an overclock or stock system speeds?

 

I found that to get memtest to even pass at stocks speeds with only the RAM set to 4-4-4-12 I had to up the northbridge voltage to 1.45v. This allowed it to pass memtest for 12-16 hours (before I killed it, there were no failures) depending on settings. I believe it may have still failed the prime95 blend test though. I've run so many tests lately it's hard to remember what I have and haven't tried.

 

Here are the recommended settings from RAM GUY (on a different Asus board)

 

Motherboard make and model: Asus P5WD2 or M2N32-SLI Premium/Deluxe

Each pair is tested and packaged together using the following settings:

AI Over Clock Tuner: Manual

CPU External Frequency: Manually set to 200MHz

DDR2 SDRAM Clock: Manually set to 800MHz

PCI Express Freq: Auto

PCI Freq: 33.33

Performance Mode: Standard

DRAM Timing Selectable: Manual

SDRAM CAS Latency: 4T

SDRAM RAS to CAS Delay (tRCD): 4T

SDRAM Row Precharge (tRP): 4T

SDRAM Active to Precharge Delay (tRAS): 12T

SDRAM Write Recovery Time: 5

Write to Precharge Delay: 15 (If it's Listed)

Command Rate: 2T

DDR2 SDRAM Voltage: 2.1

CPU Core Voltage: Auto

FSB Termination V: 1.50 V

MCH Chipset V: 1.65V

ICH Chipset V: 1.20V

All other settings are motherboard defaults.

Maximum DDR2 recommended VDIMM: 2.1 Volts

 

In particular the FSB termination at 1.5V and the MCH (memory controller) at 1.65V are what interest me. I was trying to keep mine as low as possible so I don't torch the northbridge, and since I don't know what the "auto" setting uses, I was trying to stay at 1.45V. It looks like I may have to push the NB, and possibly FSB, voltage a little more in order to get my machine blend stable.

 

As it stands right now I can get the CPU to run 3.2GHZ at 1.3V Vcore, which seems rock stable in small prime95 tests. I can get the memory to run for long periods of time in memtest at 400mhz with various settings including much tighter than the specified ones (4-4-3-5 was my best I think). So the only culprit I can think of when it comes to getting this thing stable when simultaneously testing CPU and memory is the CPU to memory link, which is the FSB/northbridge.

Link to comment
Share on other sites

I did a bunch more fiddling last night. CPU seems fine at 3.2GHz on 1.3V Vcore. My small fft dual prime95 ran for 16+ hours before I killed it.

 

Changing NB and FSB voltages seemed to have little effect, just as you said. I've pushed them anywhere from a little over to max values and blend still fails fairly quickly. I installed a NB cooler with a fan out of paranoia of frying my NB as well (400Mhz plus 1.65v is quite a bump from the stock 266MHz and 1.25v, if that's what they use on Auto).

 

I'll keep messing with it this weekend when I have more time for trials. I'll probably go back to stock and see if I can replicate the problems with blend, as you said you have.

Link to comment
Share on other sites

At my OC'ed settings:

 

5-5-5-18-6-42-10-11-10-15 = No fails for 3 hours before I killed it the first time. No fails for 9 hours before I killed it a second time.

 

4-4-4-12-6-42-10-11-10-15 = Failed blend in 0 minutes first time and 1 hour the second time.

 

My OC settings are:

 

400MHz FSB

800MHz RAM

100MHz PCI Expcress

33.33 PCI

Spread Spectrum Disabled

Vcore 1.3V

RAM 2.1V

FSB 1.4V

NB 1.55V

SB 1.6V

ICH 1.057V

 

RAM as listed above. All CPU extras (C1E, Vanderpool, etc.) disabled except the XD bit feature. I've gotten this setup to run for 16+ hours with small fft's, so I'm pretty confident it's CPU stable at 3.2GHz.

 

I will try fully stock 266MHz FSB and "Auto" settings with 2.1V 4-4-4-12 RAM later today/overnight.

Link to comment
Share on other sites

The 266MHz FSB / 400MHz RAM test ran through last night. I had everything to Auto except the RAM voltage to 2.1v and manually setting the 266/400. RAM was at 4-4-4-12-6-42-10-11-10-15, all the CPU extras were disabled except the XD bit support. It ran overnight just fine, maybe like 6-7 hours.

 

When I woke up to check on it Windows BSOD on me when I clicked the mouse. That also happened at 3.2GHZ 5-5-5-18 shortly after I typed the post above. I've had it give that exact same style of BSOD (right after I click the mouse to do something) off and on over the last few months and on almost completely different hardware configurations (I just upgraded to this setup a few weeks ago, recycling parts here and there).

 

Since it's hard for me to pinpoint the cause of my instabaility, and it seems to run fine left alone, it's hard for me to come to any conclusions. I seem to be able to get it prime95 blend stable at 266MHz FSB, 400MHz RAM at 4-4-4-12, at least overnight. Same with 400MHz FSB, 400MHz RAM at 5-5-5-18.

Link to comment
Share on other sites

I probably won't push the CPU voltage any more at 3.2GHz. With my current cooling setup I'm already getting core temps (reported by coretemp) at 58-59c fully loaded at 1.3V Vcore. I believe Intel recommends 61c as the maximum. An option is to fall back to 320MHz FSB and run 4:5 ratio, giving me more headroom to play with CPU voltages to see if that helps anything. It will also give the CPU and NB more breathing room since they'll be running at 320 instead of 400. Although reports from others seem to show this board easily going up to 450+ MHz ranges, I wonder just how "stable" those systems really are.

 

My BSOD still concerns me and the fact that I can get it at virtual "stock" settings. It seems almost mouse related, as the computer tends to crash when I click a button, for instance to close a window or a tab. Of course that's not really related to this thread of forum since it doesn't appear to be related to my current setup. I've had this happen prior to having the Asus mobo and Corsair RAM, and have even had my girlfriend complain that it's happened to her computer as well.

 

But I will try your suggesting of playing with CPU voltage a bit to see how that factors into the interaction. As it stands now 1.3v, 400MHz FSB, 3.2GHz CPU is rock solid in small fft's on both cores. But that fits in the cache of the CPU and doesn't test the CPU/memory interface, which is precisely where I'm having my problems. I'm not sure how VCore affects the interface to the NB, I figured that would be FSB voltage instead, but I guess at some point the FSB and core have to interact. Or is the FSB voltaged based on the core voltage, and FSB is only the termination voltage, as it says?

 

EDIT: I've also tried NB voltages up to the BIOS maximum of 1.65v with no success.

Link to comment
Share on other sites

I just discovered something new.

 

Mem set to 533MHz 4-4-4-12 2.1v - system stable, 1h orthos blend test passed

 

Mem set to 666MHz 4-4-4-12 2.1v - system stable, 1h orthos blend test passed

 

EDIT:

Mem set at 732MHz 4-4-4-12 2.1v - orthos bland test failed after 50 minutes

 

Mem set at 700MHz 4-4-4-12 2.1v - orthos bland test failed after 3h

 

To recall, orthos failed at 800MHz 4-4-4-12 2.1v as its mentioned at the beginning of topic.

 

Will see where the wall is.

Link to comment
Share on other sites

I've been back to the stock settings as well. I managed to get prime95 blend to fail in 8 minutes last night with 2.1v 4-4-4-12(-6-42-10-11-10-15). I might throw it at a long memtest at 2.1v to see if that uncovers any errors, but in the past my RAM has passed that just fine.
Link to comment
Share on other sites

For me, for now, everything at full Auto in the JumperFree and NB config pages. When I tried 4-4-4-12 at 2.1V I turned JumperFree to Manual and changed the RAM voltage to 2.1V. I left everything else at Auto or default. CPU Config had all technologies like vanderpool, C1E, and speedstep disabled, except for XD bit enabled. NB is set to 4-4-4-12-6-42-10-11-10-15, which is not quite default plus 4-4-4-12. I upped the last number because you suggest moving it from 10 to 15, and the 11 I get from the settings the RAM uses if you go by the SPD DDR2-800 default, which I believe is 5-5-5-18-12-?-3-11-8-15 or something along those lines.

 

Note these are from memory since my computer is at home and I'm at work. But I've been messing with it enough lately that I have a pretty good idea what I keep most of the settings at now. :)

 

I have not tested the sticks one at a time, and have actually not run memtest in a while. I figured my system was fine a few weeks back when I was getting memtests to run for 20+ full iterations at any setting I could throw at it. It wasn't til I moved to prime95 blend that I started tending to have problems, probably since I was pushing the testing the CPU-memory interfance while the system was being stressed, instead of memtest which does stress the entire system as much.

 

And I'm using the 1004 BIOS on the board.

Link to comment
Share on other sites

  • Corsair Employees
Please Change ‘Write to Precharge delay’ in the BIOS (same page as for latencies) from default 10 to 15 and then test the modules again with the Voltage set to 2.1 Volts and the tested settings set manually! Then test with http://www.memtest.org to be sure! If you still get errors, please follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it! However, if you get errors with both modules that would suggest some other problem and I would test them in another system or MB to be sure.
Link to comment
Share on other sites

Yes, write precharge delay to 15. RAM to 4-4-4-12 2.1V, DDR2-800, 266FSB, etc. Fails blend really fast (1-2 minutes in certain caes) but will memtest for 14+ hours with 0 errors, 30+ full iterations, before I killed it. It really does lead me to believe it's system related, either the board or the BIOS, not memory related.

 

1.9V - Windows blue screen on bootup

1.95V - blend failed in about 2 hours

2.00V - blend failed in 5 hours (and the small fft on the other core failed in 2 hours :(:)

2.05V - blend failed in 2 minutes

2.1V - as I said above, very fast fails for me, 1-2 minutes.

Link to comment
Share on other sites

After my last tests on voltage, I've started playing with some of the hidden subtimings in MemSet. In particular the "CS# to MCH-ODT Latency" intrigued me. If you move from CAS4 to CAS5 in the BIOS, everything reported by MemSet stays the same except this setting (and the CAS, obviously).

 

At 4-4-4-12 the ODT Latency is set to 2.

At 5-4-4-12 the ODT Latency is set to 3.

 

So I unlocked the subtimings in MemSet and am running some experiments starting from 5-4-4-12 set in the BIOS.

 

CAS 4, ODT 2 (BIOS will set this if you select CAS 4) - 3 min blend failure

CAS 5, ODT 2 - 0 mins blend failure

CAS 4, ODT 3 - Been running now for about 30-40 minutes.

CAS 5, ODT 3 (BIOS will set this if you select CAS 5) - Prior tests at CAS 5 always seemed to run for extended periods of time.

 

I did some digging and found ODT is On Die Termination. Actually it didn't take that much digging, it's right here on the product web page. http://www.corsair.com/corsair/xms2.html ;):.

 

I'm not sure if ODT implementations differ from vendor to vendor or if there are performance levels a module is expected to conform to at various timings. But there seems to be either a disconnect between Asus and Corsair on this setting, or my Corsair modules aren't as tolerant to pushing the ODT latency as they should be.

 

I'll update again in the morning after my torture tests have had more time to run and my brain has had some rest. It's late and my brain is a bit melted from a long day. :):

 

PS: The RAM is running at 2.05V right now I believe. It was the last voltage I used in my testing for my previous post, and I was using the "change only one thing at a time" methodology of testing when I started messing with the MemSet subtimings.

Link to comment
Share on other sites

Update: CAS 4, ODT 3 ran for 3+ hours before it failed overnight. I'm running 4/4 now to see what happens. This is still at 2.05v. I'd like to put together a set of 2.1V experiments as well in the next couple of days to see what happens. It just takes time. :):

 

There are probably other settings that change under the hood when we make changes, but this is one of the few I have visibility of and control of. The other two in MemSet that the BIOS appears to move are the "All Precharge to Activate" and "All Precharge to Refresh Delay" settings. At 4-4-4-12 these are both 4, and 5-5-5-18 from the SPD they are 5. At 5-4-4-12 they are both 4, so they're tied to RAS->CAS or RAS precharge. I just haven't figured out the relation yet. That's another experiment I could try after this ODT latency stuff.

Link to comment
Share on other sites

Sorry for all the spam, my wheels just keep on turning. I'll also try lower voltage experiments as well, if possible. The reason for this is I recall the system being rock solid at 5-5-5-18 from the SPD. This "should" be at 1.8V to comply with the JEDEC and get the board to boot initially. I wonder what happens at 5-5-5-18 and 2.1V. Perhaps pushing the voltage allows faster operation, but creates some issues with the termination circuitry.

 

And I'm also entertaining the idea that the ODT could be on the MCH end, given the name of the latency being "CS# to MCH-ODT latency." I'll have to look in the P965 datasheet a little closer and see if there is termination on both ends, if that's even possible. I definitely found some registers controlling ODT latencies but didn't pay close enough attention to see if they were on the RAM end or the MCH end.

 

At this point I know enough just to get me in trouble I think. ;): If this is getting too technical just let me know, I just like to know what's going on here.

Link to comment
Share on other sites

My tests haven't been proving as successful as I had hoped. At CAS 4, 2.05V:

 

ODT 2 = 3 min fail

ODT 3 = 3 hour fail

ODT 4 = 5 hour fail

 

At CAS 4, 2.1V:

 

ODT 2 = 6 hour fail

 

This previous test is what you'd get setting the board at 4-4-4-12 at 2.1V anyways. I'd run this a day earlier and gotten a 1 minute failure. I think of failures as more of a probability. The more unstable, the more likely your prime95 is to fail early, but it still has chances to go for extended periods of time. Similarly a slightly unstable system could fail early rather than run for extended periods of time.

 

So my hopes that ODT settings would clear some issues up don't seem to have been realized. I'm back to my original hunch that it's more a board/bios problem than anything else. The RAM can run memtest for a long time without errors at 4-4-4-12 2.1V, so I know they're not bad sticks. But when the system is pushed, something in the system just falls over, and it's tough to pinpoint.

Link to comment
Share on other sites

when i set mem to 667Mhz 4-4-4-12 2.1v the system is rock solid, orthos blend test ran for over 12h, upping to mem 700Mhz with same timings and volts allows orthos to run only for 3h.

 

Dunno what to think about it, maybe the memory overheats:confused:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...