Jump to content
Corsair Community

TWIN2X2048-8500C5D Not Booting


tmushy

Recommended Posts

So I purchase the

TWIN2X2048-6400C4D ram after reading some review that said it overclocked well. So when I get it I do some research turns out it doesn't overclock at all since they changed the IC. The ram worked fine in my pc. I email corsair asking them if I can take part in the upgrade program and still no response

 

IM like ok ill take a loss and ebay it. Then I go buy some TWIN2X2048-8500C5D and shell out 400 bucks. Now I put it in and it doesn't even boot my pc. It doesn't even go past the "Memory Testing" part in Bios! Im using stock bios nothing changed to it with a GIGABYTE GA-965P-DS3 P965 775 motherboard and E6400 CPU

 

PLEASE HELP SOMEONE id hate to RMA this or return it with a 15% restocking fee

Link to comment
Share on other sites

  • Corsair Employees
I am sorry if you want to get our XM2S8500C5 modules I would suggest you talk to the reseller and see if they will let you send them back for credit. But if not I have no problem replacing them, but I would try them one module at a time and reset the MB bios to make sure its not some other problem.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...