Jump to content
Corsair Community

4GB Voyager USB drive failing time after time


Recommended Posts

I have used the 4GB Voyager USB drive for about 3 months and now experience Bad Device errors everyday on one of several desktop and laptop computers. My other 1GB flash drive never has these "Device not recognized" errors under XP Professional. I have tried 4 laptops and 1 desktop utilizing the computers existing USB port but still get the same error at least once a day as I use multiple computers. The sometime works no problem when plugged and other times it will fail when after opeing a document or transferring files. I get the bad device error - usb device not recognized and have to reboot in order for it to recognize the device again. Other times the drive shows up but with no label on the drive and when it is opened the drive is blank. I'd like to continue to use Corsair flash drive but cannot figure out why for the past 105 days I am continually experiencing this error. The print on the USB connector is : 628CASOG (top side) and 0627268-0 on the other.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...