Jump to content
Corsair Community

4 Gig Flash drive - Suddenly Unformatted, Write protect Error


Recommended Posts

Hi there,


My previously trusty 4 gig Flash Voyager which I had been using without any problems for the 6 months since I bought it was suddenly unformatted when I plugged it in today!


I tried a file recovery program to read the data "PC Inspector File Recovery".

It complains saying:

bad parameter in boot sector (65281) > 32768!

bad parameter in boot sector: root directory cluster (4294967295) > count of clusters


Having then prepared myself to lose all my data, I attempted a format in windows to be told

The disk is write protected.


I tried the ExRecover application but it says

Writing configuration fail!



What can I try next or is it just busted?




Link to comment
Share on other sites

  • Corsair Employees

Please try to format the drive from a command prompt with the following syntax:

Format (X:) /FS:FAT32 /U (X=the drive letter assigned to the Flash Voyager)

If you still have problems, let’s get it replaced. Please use the RMA request found in TSXpress or follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it!

Link to comment
Share on other sites

Output from cmd line


[C:\]format g: /FS:FAT32 /U

Insert new disk for drive G:

and press ENTER when ready...

The type of the file system is RAW.

The new file system is FAT32.

Verifying 3968M

Cannot format. This volume is write protected.


Will fill out replacement req form now.




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...