Jump to content
Corsair Community

What is wrong with my new 8GB flash drive?


playloud

Recommended Posts

CORSAIR Voyager 8GB Flash Drive (USB2.0 Portable) Model CMFUSB2.0-8GB

 

I have only used my new flash drive one time. I was at work and transferred some of my music just to check it out. It seemed to work fine. However, now I am at home, and the drive is listed as a Removable disk, instead of the Corsair Voyager...

 

http://img.photobucket.com/albums/1003/playloud/Removable-Disk.jpg

 

 

 

If I try to click on the drive, I get this error message...

 

http://img.photobucket.com/albums/1003/playloud/not-formatted.jpg

 

I know the drive is formatted, as I put some of my music at work on the drive.

 

 

If I click yes, the only size option available is 3.87GB (it is an 8GB drive).

 

http://img.photobucket.com/albums/1003/playloud/format.jpg

 

 

 

If I try to format it anyway, the progress bar goes all the way to the end, but I get this message...

 

http://img.photobucket.com/albums/1003/playloud/unable-to-complete-format.jpg

 

 

This happened on both my computer, and my brother's computer.

 

I originally tried plugging in the device to the powered USB 2.0 hub that I have (the USB ports on the front of my case are not hooked up). While troubleshooting, I tried connecting the drive directly into the USB 2.0 ports on the back of my motherboard.

 

After unplugging it and plugging it back in many times, it did seem to work again. After I unplugged it again, and tried it again, it was again malfunctioning.

 

I have only had the drive for about a week (since Christmas), and I am a little upset that my new drive seems to be malfunctioning.

 

Is there a solution to this problem, or do I have a bad drive?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...