Jump to content
Corsair Community

1GB Flash Voyager Fault (International UK)


Recommended Posts


Please can you help?

I purchased my Corsair Voyager 1gb Flash last August and since then all has been fine accept for the past week the drive is experiencing errors. The memory stick is used on a number of different machines running Win2000 SP4 and WinXP SP2 and all are giving the same error/errors. The blue light is working ok when inserted.


1: PC's not recognising drive as "Corsair" and just loading generic drive volume

2: PC's keep asking me if I want to "format drive" then windows informs me it "cannot complete the process"

3: When I try to copy data to flash drive via "MyComputer" i get the following error: "cannot create or replace Ezrecover_corsair_49140:cannot find the specified file.Make sure you sepecify the correct path and file name"


4: I have tried the "Flash Voyager Utility" and the application hangs after approx 10 minutes and has to be terminated via task manager.


I brought this device in the United Kingdom and the retailer is stating that "Branded goods" after 30 days must be sent back to the manufacturer for any warranty claims.

Do you have a returns address in the UK or do I have to send it to the USA for replacement?


Look forward to your reply.


Cheers Malcolm

Link to comment
Share on other sites

  • 3 weeks later...

I would just like to say what a great warranty service Corsair has.

After posting my 1Gb unit off for repair from the UK, 5 days later I received a brand new replacement flash drive.

Fantastic service and a big thumbs up to those in the despatch centre.


I’ve always recommended your products and this transaction just confirms that point.


Many Thanks




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...