Jump to content
Corsair Community

ASUS P5B Deluxe + TWIN2X2048-6400C4


Recommended Posts

Hello, all. This is my first posting here.


After reading through several posts here and Googling, I have made the plunge and am replacing my Crucial "10th Anniversary" DDR2 DIMMs I got in late November from newegg.com due to ongoing MEM86+ failures.


I have decided to go with Corsair based on largely positive reviews and on the support of this board and have selected TWIN2X2048-6400C4.


I hope I am not disappointed and am glad I am getting the $40 rebate that's going on right now on the RAM from newegg.


I surely hope my memory errors go away with these new sticks.

Link to comment
Share on other sites

Hi Snowdrift,


I, like you, came here to deal with system issues. I came away with my problems cleared up. This has happened a few times since and each time Corsair's help has been exemplary so I now come by to help myself.


I have installed this ram on that motherboard on more than a few occasions with no problems. You will have to enter the BIOS to set the DRAM correctly but we can easily help you with that.


I also totally understand you wanting to have a system working without "issues". :D:

Link to comment
Share on other sites

Well, I found the specs somewhere else on these Corsair DIMMs. I just need them to come in from newegg now! ;-)


I am so disappointed by the C R U C ! A L "10th Anniversary" sets I got. Everybody praised them, but one of them is bad and newegg.com is requiring both DIMMs back before I can get a refund. They are CAS3 but if you can't get them to pass MEM86+ then that's of little help.


In a way, I guess, I hope it is those 6-week-old DIMMs that are screwy; otherwise, I will have to consider the mobo, which I would hate to go without and which is far more troublesome to return.


When I did my last machine build 2-1/2 yrs. ago, things were so much simpler. Everything changes so fast, it's hard to keep up unless you're building all the time (which I guess is what the manufacturers must want).


Here's hoping I get the new sets Friday! Otherwise, it's after the 1st.



Link to comment
Share on other sites

Ram Guy, I plan on using the stock settings for the RAM I have ordered as outlined above (which should arrive tomorrow). Here is the thread with the specs (CAS4) I am going to use:




I have the exact same mobo and memory as outlined in this previous case from a couple of weeks back.

Link to comment
Share on other sites

Well all of my components have now arrived so I'll be building over the weekend using many of the same parts detailed by snowdrift. Summary of main parts:


ASUS P5B Deluxe Wi-Fi

Intel Core Duo 2 E6600 (2.4ghz)

VapoChill Micro Ultra Low Noise

Corsair TWIN2X2048-6400C4


If I understand the motherboard manual correct the automatic configuration will set the memory at 667mhz and not the 800mhz that it can support. Should I be manually setting the memory to get it up to speed before I run MemTest (also planning on using Sandra burn-in wizard) or check the stability using all the default settings first?


Looks like I have a steep learning curve ahead of me as the memory landscape has really changed since I first started building computers. Any tips and advice gratefully received.

Link to comment
Share on other sites

... on my spec (as above):




CPU-Z 1.38 report file




Number of processors 1

Number of cores 2 per processor

Number of threads 2 (max 2) per processor

Name Intel Core 2 Duo E6600

Code Name Conroe

Specification Intel® Core2 CPU 6600 @ 2.40GHz

Package Socket 775 LGA

Family/Model/Stepping 6.F.6

Extended Family/Model 6.F

Core Stepping B2

Technology 65 nm

Core Speed 2400.1 MHz

Multiplier x Bus speed 9.0 x 266.7 MHz

Rated Bus speed 1066.7 MHz

Stock frequency 2400 MHz

Instruction sets MMX, SSE, SSE2, SSE3, SSSE3, EM64T

L1 Data cache 2 x 32 KBytes, 8-way set associative, 64-byte line size

L1 Instruction cache 2 x 32 KBytes, 8-way set associative, 64-byte line size

L2 cache 4096 KBytes, 16-way set associative, 64-byte line size


Chipset & Memory


Northbridge Intel P965/G965 rev. C1

Southbridge Intel 82801HB (ICH8) rev. 02

Graphic Interface PCI-Express

PCI-E Link Width x16

PCI-E Max Link Width x16

Memory Type DDR2

Memory Size 2048 MBytes

Memory Frequency 400.0 MHz (2:3)

CAS# Latency (tCL) 4.0 clocks

RAS# to CAS# (tRDC) 4 clocks

RAS# Precharge (tRP) 4 clocks

Cycle Time (tRAS) 12 clocks




System Manufacturer System manufacturer

System Name System Product Name

System S/N System Serial Number

Mainboard Vendor ASUSTeK Computer INC.

Mainboard Model P5B-Deluxe

BIOS Vendor American Megatrends Inc.

BIOS Version 0804

BIOS Date 10/20/2006


Memory SPD


Module 1 DDR2, PC2-6400 (400 MHz), 1024 MBytes, Corsair

Module 2 DDR2, PC2-6400 (400 MHz), 1024 MBytes, Corsair




Windows Version Microsoft Windows XP Professional Service Pack 2 (Build 2600)

DirectX Version 9.0c

Link to comment
Share on other sites

snowdrift: Hope you don't mind me joining in on your thread but I thought since we are using similar components it might be useful to use the same topic so that we can compare notes if needed. If you'd rather I posted under my own topic then please tell me.


I have the basic components installed inside the Lexa (what a lovely case that is to work with and very quiet) along with a optical drive to boot off and run MemTest. So far I have updated to the latest BIOS and manually set the memory to DDR2-800 with 2.1volts and changed the memory timings. The only other change is to disable legacy USB support as recommended (good job I was able to get hold of an old non-USB keyboard :eek: )


Am onto the 2nd pass of Memtest now with no errors and 1 pass so will leave this running for a few more passes just to be sure. Shame that Memtest can't report on the chipset as it shows useful information when I run it on the P4C800-E Deluxe.


Next step, assuming no MemTest errors, is to install XP Pro SP2 and Sandra 2007 to stress test the machine and check out my temps. Will keep you updated on my progress...

Link to comment
Share on other sites

A quick question: I'm now on the 6th pass (5 without error) and a single fail has just occurred -- is the odd error to be expected (after all this isn't ECC ram) or is that an indication that something isn't quite right?


Test: 6

Pass: 5

Failing Address: 00021b27310 - 539.4MB

Good: fffffeff

Bad: bffffeff

Err-Bits: 40000000

Count: 1


Will leave MemTest running over night to see what happens...

Link to comment
Share on other sites

I have only changed the frequency (DDR2-800), the voltage (2.1v) and the timings as per the Corsair recommendations:


SDRAM CAS Latency: 4T

SDRAM RAS to CAS Delay (tRCD): 4T

SDRAM Row Precharge (tRP): 4T

SDRAM Active to Precharge Delay (tRAS): 12T

SDRAM Write Recovery Time: 5

Write to Precharge Delay: 15


FSB is 1064 (4x266) and multiplyer is locked (9x) to give a CPU speed of around 2.4ghz which is spec for an E6600. Another error has just appeared:


Test: 2

Pass: 7

Failing Address: 00062f27310 - 1583.4MB

Good: ffffffff

Bad: bfffffff

Err-Bits: 40000000

Count: 1


Personally 2 errors in over 3 hours of MemTest, and 7 passes, doesn't seem a big deal but then I accept that I'm not an expert. I would expect some errors or else there would be no need for ECC memory?

Link to comment
Share on other sites

Yes I have disabled legacy USB support and I'm using a PS/2 keyboard. I'm in the UK so I can't use your RMA facility and at the moment replacing them seems a little extreme -- obviously I also accept that you know more about all this than I do.


I'm going to leave MemTest running overnight as planned and then will continue on with running Sandra 2007 burn-in and also Prime95 too as that is good for showing up memory/CPU issues.

Link to comment
Share on other sites

... sounds similar to what I was experiencing with the Cruc!al "10th Anniversary" DIMMs I RMA'd. I would get a single error in Test #7 (on each MEM86+ pass).


The Corsair DIMMs I got to replace them are not giving me those problems. I let it run for a little over 3 hrs. tonight and no sign of a problem.


I would not accept a single error in the test if I were you, or you will always second-guess it when you have later problems.

Link to comment
Share on other sites

The problem is that I have no direct access to Corsair here in the UK so my only other option is to return it to my supplier. I'm now on 4 errors and it has taken nearly 11 hours to encounter those so I very much doubt that any returns handler is likely to do anything more than a couple of passes of MemTest.


If I leave MemTest running for a few hours on my existing P4C800-E Deluxe system, with TwinX2048-3200PT memory installed, I'll eventually get around the same number of memory errors and that system is rock solid under both XP and Vista.


Please don't think that I'm not taking peoples advice seriously, I certainly am, but I think I need to do some Windows testing in order to have some proof. I'll take a picture of the MemTest screen as evidence. Thanks for all the input and I'll update once I have Prime95 installed and running.

Link to comment
Share on other sites

I just finished running Memtest86+ for over 6 hours without a single error using the CAS4 spec for this RAM. I have boxed up the old DIMMs I am replacing and will be keeping this Corsair set. I am glad this problem seems resolved. Thank you, Ram Guy.


One other thing, I did *not* disable legacy USB support under BIOS and the tests still worked without a hitch for me. I *did* set it to "Auto," which probably means it did in fact default to "off" since I do not use any USB 1.0 devices on this machine.

Link to comment
Share on other sites

Looks like you have a great stable system there, am very envious! :):


I now have XP SP2 installed with the latest Intel drivers for the ICH8R with the two drives installed as RAID0 with a single 150GB partition for now. I then installed the chipset INF file along with the sound, network, and graphics drivers.


Prime95 has completed its benchmark and I'm now running the stress test so far without incident (1024K and 8K passed). Will let Prime95 run for a few hours before moving onto Sandra XI to do the burn-in wizard.

Link to comment
Share on other sites

One other thing, I did *not* disable legacy USB support under BIOS and the tests still worked without a hitch for me. I *did* set it to "Auto," which probably means it did in fact default to "off" since I do not use any USB 1.0 devices on this machine.


The issue is with the BIOS/Legacy USB and Memtest. Not all BIOS's are effected by this bug but some are so it is far easier to just ask people to test with it disabled than try and decide which ones are effected and which ones are not effected.

Link to comment
Share on other sites

I left the Windows Memory Diagnostics running last night, something I'd downloaded from Microsoft.com a while back, and it did 128 passes overnight without a single error. I'm now running the program using the more thorough tests so will see how that goes.


I let the thorough tests run three times and no errors occurred. I might well leave it running longer overnight tonight.

Link to comment
Share on other sites

Although technically that program is still in beta, I know the one from M$ you're talking about, it does the same sorts of tests. It should be sound as a reference.


I still think MemTest86+ v.1.65 (10/01/2005) is slightly more comprehensive, but either should work for you. Version 1.66 is imminent and is supposed to address a very few bugs and recognize more recent chipsets.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...