Jump to content
Corsair Community

Different Revisions working in the same system!


Recommended Posts



I think I’m also having a compatibility issue with my memory sticks. My motherboard is a DFI LANPARTY UT nF4 Ultra-D with an AMD Athlon64x2 4800+ processor, and two pairs of Corsair TWINX2048-3200C2PT memory sticks. I’m not able to use the 4 GB memory capacity because the system doesn’t post. I can use 2 GB at a time and both pairs work perfectly, but I can’t mix them. One pair is XMS3202v2.1 0635198-0 and the other one is XMS3202v2.2 0635182-0.


Do they only need to have the same revision number (v2.1 or v2.2 for this example) to work together, or do they also need to have identical lot numbers? I mean, are lot numbers also critical?


Thanks in advance for your help.

Link to comment
Share on other sites

  • 2 weeks later...
  • Corsair Employees


I would try a bigger/better PSU with your configuration. the PSU you have is ok but marginal at best for out put quality! Or if you can test these modules in another to be sure but they should work together at the default settings.

Have you tried to install 2 modules in slots 3-4 and see if the system will post?

Link to comment
Share on other sites



Thanks for your suggestions. I will see if I can get another motherboard to test the four modules together, and I’ll also try to change the power supply. For the moment, I’ve tested again my sticks (see TEST.TXT attached).


What I can conclude from these tests is that I can mix revisions (you said it should work, and it did) but only using 2 GB at a time. If I try to place three or four modules together, my system doesn’t post. I’ll see if I can test the 4 GB on another machine. Thanks again for your help.


By the way, what PSU would you recommend for my configuration?


Link to comment
Share on other sites

  • 1 month later...

Be aware some motherboards can't post with 4GB of RAM as some of their stated 4GB capacity has to be reserved for onboard processes. The controller simply can't address it.


See this Vista test with 6GB of memory:




I would suggest you try updating the BIOS and / or contacting your motherboard manufacturers support line to check if it can boot 4GB successfully.


Also, try putting in 3GB and see if it works as this might indicate an addressing problem with the mobo if 3Gb is successful but 4GB not.



Link to comment
Share on other sites

  • 1 month later...

Hi Alsone,


I've found an interesting document (in Spanish) about systems with 4 GB of RAM and it's been quite discouraging for me. If you can understand the language, have a look at http://www.multingles.net/docs/jmt/4gbmem.htm ("Problemas con 4 GB o más de memoria. No se ve toda la memoria instalada (32 – 64 bits)"). Look at this section for understanding the hardware problem: "Introducción al problema desde el punto de vista hardware".

So, I was already aware of this issue.


The firmware I'm using is the latest from DFI. Sorry, I forgot to mention it before.

DFI > Home > Download > LANPARTY UT nF4 Ultra-D > BIOS


BIOS Details

Revision: A

Date Code: 2006/04/06

File: NF4LD406.EXE

Size: 833,583 bytes


I was going to contact DFI about this issue, but there's been a problem with DFI Street (DFI's forum) recently, and I haven't checked their site again after that. This is something I plan to do soon. Thanks for your reminder.


And finally, I've already tried the 3GB option. Just have a look at the "test.txt" file attached to my previous post. As I explained before, "If I try to place three or four modules together, my system doesn’t post."


Thanks for all your suggestions.


Ram Guy: I've unplugged the power cord from the video card and the DVD recorder, to see if it was a PSU problem, but I haven't been able to pass the memory detection anyway. So I'm almost sure that a bigger PSU wouldn't solve this issue. I'll keep searching for more possible solutions.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...